Linux edit commit message automatically aborts


#1

I have tried to set atom to be git’s default editor both with

git config --global core.editor atom -w

and

 git config --global core.editor atom

But neither seem to work. It will open the commit message window in atom fine but git automatically goes to Aborting commit due to empty commit message.

Ubuntu 14.04
Atom 0.116.0-4960a63


#2

Just out of curiosity, have you tried atom --wait?


#3

Same thing as the other two I’ve tried :frowning:


#4

Weird. I have one other idea, do you have the Autosave package enabled?


#5

Nope, I’m not to sure what is causing it either


#6

Well, then try this:

  1. Exit out of Atom completely
  2. Go to your ~/.atom directory
  3. Rename the packages directory to packages-backup
  4. Try again

#7

Still nothing :confused: Is this issue worthy? Does anyone experience the same problem?


#8

I haven’t heard of anyone running into this issue. @AbeEstrada, do you run Ubuntu? Can you confirm or shed light on this?

@Frozenfire92 you can always file a bug on Atom Core. Perhaps the Atom team has some ideas.


#9