Linux: Atom doesn't run in Midnight Commander


#1

Atom doesn’t run in Midnight Commander in Linux (I’ve tried both atom and the exact path – nothing happens, no output). Upon bash -e /usr/share/atom/atom I get /usr/share/atom/atom: cannot execute binary file. The terminal emulator in which Midnight Commander runs is Lxterminal, and in bare Lxterminal both atom and /usr/share/atom/atom run. Any ideas on workarounds or what might be causing this? [Atom ver. 1.2.3; Midnight Commander 4.8.11]


#2

How did you install Atom?


#3

I know this doesn’t answer your question, but I actually do things the other way round. Instead of running Atom from a file manager such as Midnight Commander, I run a file manager embedded in Atom. atom-commander implements the dual pane design like that of Midnight Commander. With it you can navigate the file system from within Atom in a way that you are familiar with without needing to switch to another application.

It might not be as feature rich as Midnight Commander, but I personally find it very convenient.

Sorry for not being able to help with the actual issue, but maybe you can benefit from something like this since you are already used to a dual pane file manager.


#4

I installed atom from the atom.io deb file more than 2 years ago


#5

Well, that’s your first problem, and I feel like a doofus. I didn’t notice that you put 1.2.3 for your Atom version, possibly because the current version is 1.23.3. You really should update Atom.