Linter scoping bug

I have installed rubocop and erb linters.
linter-erb doesn’t work if it has opened only .erb files.
if it has separately opened .rb files then it lint erb with ruby linters.

Have you considered posting that issue in the package’s github issues page? Doesn’t seem that it has anything to do with Atom core. You could also be missing some configuration, looks like the package is not activated unless you open .rb files.