Linter-gcc is not working on Windows


#1

I have followed every step from this link - https://github.com/hebaishi/linter-gcc/wiki/Windows-Users-Guide

This is my package settings -

These are my path links -

image

and this is my atom editor pic, its just blank

please help


Anyone using linter gcc for C/C++ Successfully?
#2

What I can see looks alright. You need to make sure that Atom has the updated PATH information. Have you closed and reopened Atom since you installed MinGW? If not, you should try that first.


#3

many times, I cant understand whats the problem


#4

Alright. I want you to install the package process-palette, open Packages -> Process Palette -> Edit Configuration, and add a command like in the screenshot below.

That’s all. Reload the configuration, open Packages -> Process Palette -> Toggle, and press the run button beside your new command. The process-palette view will show you the output from the command, and that will be the specific set of environment variables possessed by Atom itself. Check to see if MinGW appears there.


#5

By Running this - it shows

!C:=C:\Users\SHAJ\Desktop\demo pro
ALLUSERSPROFILE=C:\ProgramData
APPDATA=C:\Users\SHAJ\AppData\Roaming
ATOM_HOME=C:\Users\SHAJ.atom
COMMONPROGRAMFILES=C:\Program Files\Common Files
CommonProgramFiles(x86)=C:\Program Files (x86)\Common Files
CommonProgramW6432=C:\Program Files\Common Files
COMPUTERNAME=DESKTOP-61Q3EPI
COMSPEC=C:\Windows\system32\cmd.exe
FPS_BROWSER_APP_PROFILE_STRING=Internet Explorer
FPS_BROWSER_USER_PROFILE_STRING=Default
GOOGLE_API_KEY=AIzaSyAQfxPJiounkhOjODEO5ZieffeBv6yft2Q
HOMEDRIVE=C:
HOMEPATH=\Users\SHAJ
LOCALAPPDATA=C:\Users\SHAJ\AppData\Local
LOGONSERVER=\DESKTOP-61Q3EPI
NODE_ENV=production
NODE_PATH=C:\Users\SHAJ\AppData\Local\atom\app-1.23.3\resources\app.asar\exports
NUMBER_OF_PROCESSORS=4
OLDPWD=C:\Users\SHAJ\AppData\Local\atom\app-1.23.3
OneDrive=C:\Users\SHAJ\OneDrive
OS=Windows_NT
PATH=/cygdrive/c/Windows/system32:/cygdrive/c/Windows:/cygdrive/c/Windows/System32/Wbem:/cygdrive/c/Windows/System32/WindowsPowerShell/v1.0:/cygdrive/c/Program Files (x86)/Intel/OpenCL SDK/2.0/bin/x86:/cygdrive/c/Program Files (x86)/Intel/OpenCL SDK/2.0/bin/x64:/cygdrive/c/Program Files (x86)/NVIDIA Corporation/PhysX/Common:/cygdrive/c/Program Files/Intel/WiFi/bin:/cygdrive/c/Program Files/Common Files/Intel/WirelessCommon:/cygdrive/c/Program Files (x86)/QuickTime/QTSystem:/cygdrive/c/MinGW/bin:/cygdrive/c/Program Files (x86)/Brackets/command:/cygdrive/c/Program Files (x86)/LLVM/bin:/cygdrive/c/Program Files/Cppcheck:/cygdrive/c/AStyle/bin:/cygdrive/c/MinGW/bin/g++.exe:/cygdrive/c/Windows:/cygdrive/c/MinGW/bin":/usr/bin:/cygdrive/c/Users/SHAJ/AppData/Local/Microsoft/WindowsApps:/cygdrive/c/Users/SHAJ:/cygdrive/c/Users/SHAJ/AppData/Local/GitHubDesktop/bin
PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC
PROCESSOR_ARCHITECTURE=AMD64
PROCESSOR_IDENTIFIER=Intel64 Family 6 Model 58 Stepping 9, GenuineIntel
PROCESSOR_LEVEL=6
PROCESSOR_REVISION=3a09
ProgramData=C:\ProgramData
PROGRAMFILES=C:\Program Files
ProgramFiles(x86)=C:\Program Files (x86)
ProgramW6432=C:\Program Files
PROMPT=$P$G
PSModulePath=%ProgramFiles%\WindowsPowerShell\Modules;C:\Windows\system32\WindowsPowerShell\v1.0\Modules
PUBLIC=C:\Users\Public
SESSIONNAME=Console
SYSTEMDRIVE=C:
SYSTEMROOT=C:\Windows
TEMP=/cygdrive/c/Users/SHAJ/AppData/Local/Temp
TMP=/cygdrive/c/Users/SHAJ/AppData/Local/Temp
USERDOMAIN=DESKTOP-61Q3EPI
USERDOMAIN_ROAMINGPROFILE=DESKTOP-61Q3EPI
USERNAME=SHAJ
USERPROFILE=C:\Users\SHAJ
WINDIR=C:\Windows
TERM=cygwin
HOME=/home/SHAJ


#6

Okay. From process-palette, try the command g++ --version.

Do you see the single " character? Is that from the output or did you type it on accident?


#7

I directly copied from the output and pasted it here


#8

running the command, the output is

image


#9

here is the screenshot -


#10

Okay, so we know that g++ works from Atom. This means that linter-gcc is doing something wrong. It’s good that you have an issue open on GitHub. And you should add the screenshot of the g++ output to your issue.


#11

thanks a lot, for helping me, plz let me know if you figure out this problem later.


#12

done, alredy added the screenshot


#13

its the reply from github, by author