Linter-gcc is not working for some reason


#1


Here is the error message

Here are my settings

Is there anything I should do to fix this problem?


#2

Despite the description about the enclosing the path with with double quotes, have you tried it without? The error suggests that this might be the cause.


#3

Before I tried it without double quotes, now I am using double quotes and it is still fucking up :frowning:


#4

I don’t make much sense if the description for that setting:

  1. if g++.exe is already in the PATH, why would the package require it in an extra setting

  2. if it’s meant as an alternative to having the executable in the PATH, maybe you need to specify the folder only (omitting the file name)

Again, the phrasing of that description is terrible!


#5

Cause before I did not include the g++.exe bit in my path. Yes before I did not have the file name included in the path and it did not work.


#6

From the Windows Users Guide of linter-gcc:

The next step is to add your GCC bin directory to your system PATH. An easy way to find this directory is to enter the command which gcc in Cygwin.

Then you need to add this to your system PATH. As an example, if your PATH is C:\Windows and your GCC bin directory is C:\MinGW\bin, your new PATH should be C:\Windows;C:\MinGW\bin. Note the use of the semicolon as a separator. Please refer to the instructions below on how to change the system PATH on your version of Windows.

Finally, set the linter-gcc executable path to g++.exe or gcc.exe. Note that you MUST NOT set it to C:\MinGW\bin\g++.exe or C:\MinGW\bin\gcc.exe. You must NOT specify the full path, only the name of the executable.


#7

“C:\Program Files\mingw-w64\x86_64-7.2.0-posix-seh-rt_v5-rev1\mingw64\bin”

This is where g++.exe and gcc.exe are located.

“As an example, if your PATH is C:\Windows” what does this mean?


#8

It means that, if the contents of the environment variable called PATH are equal to the string C:\Windows, you should add to the end of the variable a semicolon and then the next directory you want to add. Don’t do that, though, because Windows has a GUI for editing environment variables. Just do it the normal way for your version of Windows. Open the Environment Variables dialog, open System Path, hit Add, and then enter the directory. Apply your changes, close Atom, and reopen it.


#9

Still not working :frowning:

THis is my linter-gcc setting

image

This is what I click on

And this is the directory I have added

Did I do something wrong?


#10

That looks right. What happens when you open the command prompt and type gcc?


#11

See the last paragraph I quoted from the Windows User Guide


#12

image

THis is what I get when I type gcc.


#13

This is what I did I am still getting an error.