[Linter] Error running Flake8

(New to this and the Forums)

Hello so I was installing Flake8 and Linter for Atom when I type Python but I am getting these errors

[Linter] Error running Flake8
See Console for more info. (Open View -> Developer -> Toggle Developer Tools)

So I checked the console and I see this whenever I get the error
C:\Users\AustinKim.atom\packages\kite\node_modules\rollbar\dist\rollbar.js:5067 [Linter] Error running Flake8 Error: c:\users\austinkim\appdata\local\programs\python\python37\lib\site-packages\pycodestyle.py:113: FutureWarning: Possible nested set at position 1
EXTRANEOUS_WHITESPACE_REGEX = re.compile(r’[[({] | []}),;:]’)
at ChildProcess. (C:\Users\Username.atom\packages\linter-flake8\node_modules\sb-exec\lib\index.js:56:20)
at emitTwo (events.js:126:13)
at ChildProcess.emit (events.js:214:7)
at maybeClose (internal/child_process.js:925:16)
at Process.ChildProcess._handle.onexit (internal/child_process.js:209:5)

**I do have some other packages installed but I dont know if one of them are causing the issue.

I am trying to learn Python so if someone knows how to fix this it would be great help!**

Changed in version 3.7: FutureWarning is raised if a character set contains constructs that will change semantically in the future.

You might need to escape some characters in your RegExp. See the [] section in the documentation.

I also am new to atom and have installed the linter-flake8 package and am getting the same [Linter] Error running Flake8 message with the following comming up on the consol.

image

Looking at the documentation referred to above I am still not sure how to fix this problem. I was wondering if anyone else has come across this and come up with a solution.

Thanks

John

I found a solution.

When I updated flake8

initially I ran the command

pip install --upgrade flake8

this returned an error so I reran limiting to current user

pip install --upgrade flake8 --user

Now it works

2 Likes

I am having the same problem, tried:

“message says: 1 [Linter] Error running Flake8 Error: Failed to spawn command flake8. says thatI should install it on path file:///Users/user/.atom/packages/linter
-flake8/node_modules/atom-linter/lib/helpers.js:130”. When I tried to use the terminal provided by Atom and cd to that directory, it doesn’t exist. Do I need to mdir…??

Any other suggestions?