Linter configuration trouble


#1

Hello…
I’m trying to configure linter for HTML, css, JS and PHP…
So i installed
apm install language-html (if you don't have language-html installed) apm install linter (if you don’t have linter installed)
$ apm install linter-tidy

and i riceved an OK message…
But it doesn’t work… I don’t understand what i have to configure yet,
i don’t understand where and how i have to write this text ‘linter-tidy’:
‘tidyExecutablePath’: null # tidy path. run ‘which tidy’ to find the path

could you do some example please?

Sorry my bad english, i’m writing from italy :slight_smile:


#2

It means you have to have the tidy executable installed, and you set point the tidyExecutablePath property to the path of the tidy executable. You can run which tidy from the command-line to see where the executable is installed.

For example:

# from the command line
$ which tidy
> /usr/bin/tidy
'linter-tidy':
  tidyExecutablePath: '/usr/bin/tidy' # replace this with the actual executable path

#3

ok…
i’ve my tidy in the folder C:/html_tidy…
first think: i have to put that string in my config, right?
so i have to do
file -> open your config. is it right?
then… if i write that string in my config and then i try to save, an error message appear…
something like "unexpected string linter tidy…
so maybe there’s something i’m wrong… where I have to put that string: i tried with
linter{
‘linter-tidy’:
‘tidyExecutablePath’: ‘C:/html_tidy’
}
and it generates an error…
so i tried to put it without linter{}, in this way
’linter-tidy’:
‘tidyExecutablePath’: ‘C:/html_tidy’

but it’s the same


#4

I think you should provide the path to the actual .exe file, not to the directory that contains it… So tidyExecutablePath: 'C:\html_tidy\tidy.exe' for example