Linter: Broken? Confused!


#1

Hello, all!

I’m a student, kind of new to programming, and I’ve been using linting plugins in Sublime Text. Then, I discovered Atom, and the only thing that is preventing me from moving over is the lack of linting.

When I use Linter, I get the error messages:

command `flake8` timed out after 5s utils.coffee:9
command `pyflakes` timed out after 5s utils.coffee:9
command `flake8` timed out after 5s utils.coffee:9
command `pyflakes` timed out after 5s utils.coffee:9

Using atom-linter instead, I get this error:

Window load time: 3111ms
Uncaught SyntaxError: Unexpected end of input index.html:1
Error: spawn cmd ENOENT                                           lint-view.coffee:54
Error: spawn cmd ENOENT
  at exports._errnoException (util.js:742:11)
  at Process.ChildProcess._handle.onexit (child_process.js:1051:32)
  at child_process.js:1142:20
  at process._tickCallback (node.js:378:11)                       lint-view.coffee:55

And on another note, whenever I start up Atom, I get the error message

Uncaught SyntaxError: Unexpected end of input 

I guess that’s expected because Atom always starts with no open file for me.

So, Linter doesn’t work at all for me. No highlighting, no nothing. And that sucks, because Atom is awesome so far. So what do I do? I’m on Windows.


#2

I haven’t used the python linters, but do you have for example pyflakes installed on your system? It’s a requirement for the linter pyflakes package to work.


#3

It turned out part of the problem was that I did not have

> C:\Python34\Scripts

added to PATH. I fixed this by going to the Command Prompt as administrator and typing

SET PATH=C:\Python34\Scripts;%PATH%

Unfortunately, the timeout error still happens! Even when I have flake8 as the only linter, it only works on and off, constantly timing out…


#4

OK, it seems I have to run Atom from the administrator command prompt, otherwise I get something along the lines of “flake8 is not recognized as an internal or external command”. How do I fix this?


#5

Setting environment variables in the command prompt won’t persist them - it will only be valid for that command prompt session. You can change your PATH using these instructions: http://www.computerhope.com/issues/ch000549.htm

Then it should take effect within Atom as well.


#6

Thank you. This worked, I was just about to post this!