License issue when publishing


#1

I’ve been able to publish my package to atom.io, but the license is greyed out. I’ve tried adjusting package.json, unpublishing, republishing, but nothing is working.

I also tried the apm publish --tag license, but it gave this error, along with the npm errors I get each time.

I’m not quite sure what to fix, my package.json is cloned from a very similar package and all I did was swap out my own text.


#2

The tag is the version that has to match package.json and the git repo tag. Like apm --tag 1.2.3. I’m not sure what you mean by license. It isn’t required.


#3

The license may not be required, but I’m still trying to get the package page to show that the content actually has a license. It just seems that the publication of the package isn’t being completed - since apm is returning a big red X after “Preparing and tagging a new version.”


#4

You haven’t supplied a valid semver version number with the --tag option. It must match the version in package.json and a version tag in your github repo.


#5

That fixed it!! Thanks