'letter-spacing` in user stylesheet bugs out cursor


#1

I’ve added a letters-spacing value of 0.01em to my user stylesheet to space out my coding font a bit, but it causes the cursor to incorrectly render its own position. It seems the cursor is not taking the new spacing in to account


Changing letter-spacing in the editor?
#2

Reload Atom and it should work


#3

Thanks. This does seem to be okay now, in 0.8.2. However now I’m noticing that changing line-height in the CSS has no effect.


#4

Ah. It seems line-height has moved to Settings now, so is being overridden there.


#5

I’m experiencing the same problem at the moment. Using Consolas at 14px with 0.5em letter-spacing (set in user stylesheet). If I remove the letter-spacing the cursor location is fine.

I have tried restarting the whole app and reloading the view, but over time the cursor position seems to slip again and appear sometimes two characters over from it’s actual position.

There was a similar issue with certain fonts in an earlier version, which now appears to be fixed. Hopefully this will get fixed soon too.

It’s obviously not the end of the world to use the standard letter-spacing, but it would be nice if this worked correctly.


#6

As an addition to my post earlier, it seems that the problem occurs when the cursor is placed on a line anywhere after a ’ (single quote) is used. Changing the quote to " (double quote) seems to fix the cursor placement.

I thought the extra information might prove useful… it’s certainly not a ‘fix’.