"Learn More" button on packages does nothing


#1

When searching for packages, they all display a Learn More button. When I click it–it does nothing.

I’m using this on Linux–I built it from source.


#2

It should launch the package page for the given package in your default browser. Have you tried opening the Developer Tools and checked to see if an error is logged?


#3

I don’t know how. I just started using this fine software today. :smile:

Let me figure out how, and I’ll get back to you.

EDIT: I actually just realized no external links are being launched in Chrome. Clicking on “Release Notes” under Help doesn’t do anything either.


#4

Yep. I can’t get any hyperlinks in Atom to work properly. Not sure if others are able to replicate. I also have no clue how to get logs, as Dev mode doesn’t seem to do anything special.


#5

On my Mac, it’s not dev mode, it’s View / Developer / Toggle Developer Tools. It’s bound to cmd-alt-i, so maybe on Linux it’s ctrl-shift-I or ctrl-alt-i?


#6

Ah. I see. Yeah, I have the Dev console pulled up then. However, when clicking a link, (for example: Release Notes under the “Help” menu), does nothing–and it doesn’t seem to throw anything into the log.


#7

How do I get a log for this? Clicking on “Learn More” when installing packages does nothing–click on “Documentation” in the Help menu does nothing… No links are linking to Chrome. All my other applications link to Chrome fine (Android Studio, Dropbox, various Linux settings, etc.). It’s just Atom.


#8

FWIW, the “learn more” buttons open for me in Safari.


#9

Someone opened an issue on the repo for this as well. So far only on Linux, but I’ll check it out on Windows later today.

Edit:
Just tried it on Win8, v125, loads in my default browser fine, so appears to be another Linux thing for the time being.


#10

Awesome. I’ll follow that then. Thank you!