Launching via spotlight causes keybinding issues


#1

(First off - I’m not sure this is the right place; I was trying to find a bug tracker.)

I just started trying Atom, and first launched it via spotlight (cmd-space atom ); this seemed to work fine, and opened the welcome text. cmd-shift-P also worked.

However, many other chorded keybindings don’t work. eg: cmd-t does not respond, cmd-shift-t (the documentation shows a capital ‘T’, so I tried that… did re-open a closed tab, though). ctrl-0 also failed, so it was very difficult to actually open a file.

The buffer navigation keys /did/ work (ctrl-a, ctrl-e, ctrl-p, ctrl-n).

I’m running on Mavericks, generally using dvorak, but I tried with a standard US Qwerty layout as well (I was actually happy to see that the behavior was the same with both).

Thanks!
–Rogan


#2

Does this only happen when you launch from spotlight? What about if you click that Atom icon or open it from the command line?


#3

Oddly, /now/ it’s working just fine, launched from any means. (and explicitly quitting via cmd-q)

Initially, I couldn’t get it to work unless I launched it from a terminal; perhaps it was an initialization issue when launched from spotlight?

I didn’t try launching it from a finder, and when I try that now, the keybindings work. It’s possible this was due to user error (maybe I was hitting the wrong keys) but I think that’s unlikely.