Latest version still locking on Windows 10


#1

Had atom running fine on Windows 10. Then this morning I was using the file explorer (left hand panel) to do some organising and atom stopped responding. I restarted the app, same problem. I restarted windows, same problem. I uninstalled, rebooted and reinstalled atom, same problem.

What can I do to get this working again? Even if this is a beta, I cannot believe the developers are letting people download a version that won’t even startup.

Any suggestions appreciated.


#2

Have you followed the suggestions in the Debugging document? Also, could you give the following information?

  • Which version of Atom are you using?
  • Can you reproduce the issue after completely exiting Atom and restarting using atom --safe?

If nothing in the debugging document helps, you may want to try the following:

  1. Exit Atom
  2. Start Atom from the command line with atom --clear-window-state

#3

I used ‘Latest Version’ in the title because I couldn’t get to the Help-About to find out the version number without crashing or locking up. I had just downloaded and installed the ‘latest version’.

Anyway, atom --clear-window-state seems to have done the trick and it has now loaded the project and so far has not crashed or locked up.

Any more info on what is going on so I can avoid it next time? Can you point me to the command line stuff, cannot see it in the docs?

Thanks for your help.


#4

The Atom binaries are stored in AppData/Local/atom. You can see what version it is there. “Latest version” is vague because there’s a stable version and a beta version out at the same time.


#5

You can also get the version information by running atom --version from the command line.

Unfortunately, whatever was causing the issue got deleted when you did the --clear-window-state. I’m not sure what exactly you mean by “to do some organising”, so it is hard to guess what may have caused the issue. (In other words, were you renaming files? Were you moving them from one folder to another? How were you doing it? Were you using the keyboard? The mouse? The menus? Something else?)

atom --help is probably going to be your best resource other than the Debugging document.


#6

Thanks everyone for your comments, it has been a great help and educational all at the same time.


#7

This still happens to me every new major windows version roll but

   atom --clear-window-state

Resolves the problem++