Latest update broke Atom for Macbook Pro OSX Yosemite 10.10.5!


#1

Well thank you for breaking my Atom.app with your latest 1.15 update! The little squirrel in the bottom right of Atom said the latest update is ready to install. I clicked Atom File>Restart and install. Now it refuses to launch. When I go to the Applications and click Atom.app it will bounce in the dock twice and then do nothing. If I try to run it from the command line via /Applications/Atom.app it still does nothing. When I try it from /Applications/Atom.app/Contents/Resources/app/atom.sh it says: “The application /Applications cannot be opened because its executable is missing”. I should note that I have done nothing else to change any configurations of Atom or my Mac.

I know its due to the update because I kept the old version 1.5.4 zip download and can install that one after removing Atom 1.15 completely. When i run the old version it will at least start and run (but is very buggy). But yet again the llittle blue squirrel is saying that the latest update is ready to be installed and sure enough, just closing Atom will cause the update to be applied and be restarted…but nothing happens. The icon will appear in the dock again and bounce a few times and nothing opens. And then Im back to square one. Talk about a frustrating user experience!


#2

Thanks for the report - do you see the same behavior running Atom from Spotlight? And what about just running atom from Terminal?

Lastly, does running in safe mode make any difference?

atom --safe

#3

I tried those as well and nothing happens. Atom does not open and it will not even appear in the dock if.

Thanks and regards,
Mitch


#4

Hmmm, do you see any output when running Atom in foreground mode?

atom -f