Language package not working: atom not recognizing file extension


#1

I’m trying to develop a simple language package for a circuit netlist simulator program that I have to use. The filetype extension I’ve specified to be recognized in the grammar\jsim.cson file is ‘jsim’. I’ve loaded it up to .atom/dev and ran atom in dev mode, then opened a file with the ‘jsim’ extension, but atom doesn’t seem to be recognizing the extension and is marking the document as Plain Text. Checking the grammar selector, the Jsim file extension can’t be found. I’m completely new to all this so I’d really appreciate any pointers on how to troubleshoot. The package repo is here: <a = “https://github.com/tjjjwxzq/language-jsim”>https://github.com/tjjjwxzq/language-jsim


#2

Dev packages should be in ~/.atom/dev/packages/package-name, but it sounds like you put it in ~/.atom/dev/package-name


#3

Nope I ran apm link --dev and my package is indeed in .atom\dev\packages
Edit: I’ve checked the Developer Packages under Settings and it also shows that my package is enabled. Are there any files I missed out in my package?


#4

@tjjjwxzq Looks like your problem is that you named the directory grammar and not grammars. I’ve just tried on my computer and once renammed I see the Jsim grammar in the languages list.


#5

Riiiiiight. Yea that was kinda dumb of me. Thanks! Now time to figure out where my regex is going wrong…