Language-babel has detected the presence of an incompatible Atom package named 'react'


#1

i am facing this error and i wondering how to fix it


#2

You have to pick which of those packages you want to use and disable or uninstall the other one.


#3

yeah … this solving the issue … but they were working fine … and actually i’ve no idea what is happen to make this error happened and i need two packages so, i asking how to make it work


#4

Do you need both packages to be active at the same time on the same file?


#5

yup … that what i need


#6

I am very curious to know what the one has that the other does not. It is easily solvable, if it is something like snippets. Even if I understood your case, there is not something I personally can do for you.

Please; may I suggest to you to open an issue at the package and motivate explicitly what lacks -
https://github.com/gandm/language-babel/issues

Regards.


#7

all i want just keep my editor like previous like this img

now after this error color of component changed no auto-complete i’ve no idea what happened or what the package do this … the problem when i disable one everything had changed
when i enable all i get the error and no auto-complete or component-color
like

please any help or package can make editor like above image … i am very thankful


#8

Hello.

What you are saying now does not feel like the same issue as what you started with. I am thinking that the Tree Sitter Parser is at fault here.

Please try the following:

  • Toggle the Tree Sitter Parser selection in the configuration to FALSE.
    (see: Error with syntax colouring )
  • Restart Atom
    (close window & open new session)

Let the forum know what you experience now - please.


#9

oooh man thank you really thank you … i toggled tree sitter parser and enable language-babel only … in very sample word IT’S WORKS … thanks


#10

Had the same problem, @danPadric solution worked for me!