[kind of solved] Linter-flake8 does not work for one project, NO error


#1

I am facing a behaviour that completely puzzles me: the flake8 linter does work well in all my projects but one.

The settings in Atom are the same (that can be found in the settings panel). Also the .flake8 file is the same. And flake8 is installed in a similar manner (venv directory of the project).

Difference is:

  • in the ones where linter-flake8 does work, if I uninstall flake8 I get the expected error message (error running flake8 > failed to spawn…); and this message goes away if I reinstall it.

  • in the one where linter-flake8 does not work, there’s no error at all (nothing happens if I purposely add errors). If I install or uninstall flake8 in the venv, no difference: there’s still no error.

It’s like the linter is completely disabled or ignored in the project where linter-flake8 does not work. I’ve searched through the different config files (.flake8 etc.) but could not find anything different between the projects.

Is there a way to selectively disable or ignore linting for one project, that I am missing? Any other clue?


#2

OK, I found out something: I changed the grammar used from Python Django to Python (Django) and it did activate the linter.

This remains troubling as:

  • setting it back to Python Django keeps the linter activated
  • the value, in both cases, is source.python.django (so, what did I really change?)
  • changing the value in ONE file of the project did activate the linter in ALL (python) files of the project, no matter the exact grammar used in each of them