Keypress not registering with keybinding resolver


#1

I’m having an interesting issue where key presses aren’t being registered on the keybindings. For example, if I press ctrl+alt+cmd+l the keybinding resolver only shows that I am pressing the modifier keys (ctrl+alt+cmd) without the l. Consequently no actions are associated with it and the window reload command is not executed like it should be. Here’s a screenshot of the keybinding resolver while I’m pressing ctrl+alt+cmd+l

I can press other character keys in conjunction with the modifier keys and I see it show up. I.e. ctrl+alt+cmd+j works just fine.

Any ideas?


#2

Hmmm, that’s odd - did you notice this just start happening recently (e.g. Window: Reload worked ok before with that key combo)?

Also, do you happen to have 1Password installed /cc https://github.com/atom/atom/issues/1794?


#3

I have noticed this more recently but I don’t have 1Password installed - although it does seem like a similar issue. I checked my keybindings and I don’t see anything else tied to this particular key binding as you can see below:

I’ve actually noticed this on a number of different character keys when using the three modifier keys I mentioned. I’ve also seen this issue affect some of my coworkers but with different key combinations.

I’ve even tried deleting Atom and reinstalling with no packages - same issue.


#4

Is there anything at all that you remember changing about your local system recently?

Based on https://github.com/atom/atom/issues/1794, it seems like something is preventing the keypress from getting to Atom (so your settings in Atom look fine, the keypress just isn’t making it to Atom).


#5

Nothing I can think of. I actually uninstalled Atom and reinstalled, I’ve disabled all packages that aren’t part of the core and reloaded but to no avail…


#6

I have a feeling this is an issue outside of Atom but do you see any difference when resetting to factory defaults?

http://flight-manual.atom.io/hacking-atom/sections/debugging/#reset-to-factory-defaults


#7

I reset all the factory defaults but no luck. Any thoughts about what might be outside of Atom that would be blocking that?


#8

Hmmm, I don’t - do you have a number of apps listed in macOS System Preferences > Users & Groups > Login Items? Wondering if there’s anything interesting you have that starts automatically.

Also, though I usually don’t ask this :smile: , have you restarted your computer?


#9

, but not i have the similar issue ( key binding is registered, but not working) with CTRL-ALT-O for the package “git control”.
I’m on Fedora 25. I did exactly the same steps as @danseethaler - removed ~/.atom ~/.config/Atom and resintalled the ATom.
I took one step further and created a new user on OS. Did not install any packages . REsolver still is not seeing the combination.


#10

The tip with “1password” made me look at what i have running - the “Clipit” has been catching the ctrl-alt-o. Dang it!


#11

Excellent feedback! I tried closing all the startup programs and everything I could think of but to no avail. So I did a little searching and found a “Shortcut Detective” app that identified the culprit - Logitech Options Daemon.

Here’s a link to the site with the Shortcut Detective app if anyone is interested. It was free and worked awesome.

http://www.irradiatedsoftware.com/labs/


Strange Key Binding Behavior - Only 'alt-cmd-z' combo