Keyboard shortcut for cycling through tabs


#21

See the new FAQ:


#27

Hello,

With these settings, I’m still not getting the expected behavior for ‘ctrl-shift-tab’: ‘pane:show-previous-item’. By expected behavior, I mean ‘alt + [’. pane:show-previous-item seems to be taking me to the previous tab historically, rather than move left. What’s the macro for that? Thanks!


#28

Have you tried using the Keybinding Resolver (Cmd+. on OS X and Ctrl+. on other platforms)? It will show you what key Atom saw you press and the command that was triggered because of it.

(It is also mentioned in the Debugging section of the Atom Flight Manual.)


#29

Thanks, leedohm. Neat utility! I noticed that the settings darwin.cson might be causing the erratic behavior. I’ve trying commenting out various combinations of the mappings below, but ‘ctrl-shift-tab’ just doesn’t behave as I’d expect. Any suggestions appreciated.

darwin.cson:

"ctrl-tab": "pane:show-next-recently-used-item",
"ctrl-tab ^ctrl": "pane:move-active-item-to-top-of-stack",
"ctrl-shift-tab": "pane:show-previous-recently-used-item",
"ctrl-shift-tab ^ctrl": "pane:move-active-item-to-top-of-stack",

keymap.cson:

‘body’:
‘ctrl-tab’: ‘pane:show-next-item’
‘ctrl-shift-tab’: ‘pane:show-previous-item’


#31

Thanks! That was very helpful. Btw do you know how to turn off the drop down panel showing tabs whenever i press [ctrl]-[tab] and [ctrl]-[shift]-[tab]? tab


#32

I had to unset the stock shortcut before setting my own:

'.platform-darwin atom-text-editor':
  'cmd-d': 'editor:delete-line'
'body':
  'ctrl-tab': 'pane:show-next-item'
  'ctrl-tab ^ctrl': 'unset!'
  'ctrl-shift-tab': 'pane:show-previous-item'
  'ctrl-shift-tab ^ctrl': 'unset!'

#33

Well, it’s simply because suddenly you need two hands to tab. If you have one hand on your mouse you are unable to tab.


#34

OFF-TOPIC

Logical comment…
though Vim users will have some thoughts on NOT using the mouse.

Ever considered controlling the mouse with your left hand?
It helped me in general ways; even if write right-handed ->
mouse on left & right hand on the keyboard.


#35

Haha, I’m not about to switch my mouse hand after 25 years of using my right hand.


#36

This is no longer a problem. I am using Atom 1.20 with Win and ctrl/shift tab cycle through tabs nicely. Also ctrl-pgup/down works.


#37

Go to the Atom menu > Open Your Keymap and add:


'atom-workspace':
  'ctrl-tab': 'pane:show-next-item'
  'ctrl-shift-tab': 'pane:show-previous-item'


#38

Thank you, this solved my problem. Just had to disable MRU Tab Switching in the Tabs package settings.


#39

@edgartheunready thanks a lot for
‘ctrl-tab ^ctrl’: ‘unset!’
‘ctrl-shift-tab ^ctrl’: ‘unset!’

I was looking for this for a long time


#40

Hi, seems I can’t focus on the project navigator with a keyboard shortcut. Is there a binding for this? Or can tab-cycling include the project navigator somehow?
I’m just getting into atom more and more… but I do like a good keyboard workflow :wink:


#41

When you say “project navigator”, do you mean the tree view (on the left by default, that shows your files), the project-manager popup, the project-viewer display, or something different?


#42

The tree view I think, it’s titled ‘Project’ and can be tucked-away leftwards.

Thanks


#43

Sorted. I needed to know it as ‘tree-view’


#44

All the bindings are there. Included toggles for focus and show/hide.


#45

Open the Command Palette with ctrl-shift-p and type “tree”. You’ll see all of the tree-view package’s commands, with keybindings for those that have them. On my computer, tree-view:toggle-focus is alt-\.

Fun side note: if the tree view is active, the commands available on the Command Palette will be different from if you have a TextEditor active, because some of the commands for the tree-view package only work if the active element is the tree view (that’s how commands like cut and copy work).

(Yes, I know you solved it, but the answer should be posted in this thread for other people to read, so I posted it anyway.)


#46

That worked. I found and edited my shortcuts with cmd+, and selected keybindings.
Good to know about the context based shortcuts. Thanks.