Keyboard layout unrecognized


#1

Hi all,

I recently installed the latest version of Atom on a Linux headless server and it seems that it does not recognize our french swiss keyboard, while the underlying linux seems properly configured.

The keyboard in Atom is a qwerty, while our keyboards are more german like ( qwertz ), which is kind of problematic for an editor.

Does someone know which linux setting Atom looks for to set the keyboard layout ? Is there a way to set this in Atom ?

No particular settings have been made on Atom, just installed two packages ( atom-beautify and language-puppet )

Thanks for your help


#2

Hi :wave:

Are you having problems when typing text or when using keyboard shortcuts?

  • What do you see if you run the following script in the developer tools console and press the Z key (On your layout, Y key with qwerty).
document.addEventListener('keydown', e => console.log(e), true)

#3

Hi,

Here is the output in the console when I press the Z key :

KeyboardEvent {isTrusted: true, key: “y”, code: “KeyY”, location: 0, ctrlKey: false}altKey: falsebubbles: truecancelBubble: falsecancelable: truecharCode: 0code: "KeyY"composed: truectrlKey: falsecurrentTarget: nulldefaultPrevented: falsedetail: 0eventPhase: 0isComposing: falseisTrusted: truekey: "y"keyCode: 89location: 0metaKey: falsepath: Array(17)repeat: falsereturnValue: trueshiftKey: falsesourceCapabilities: InputDeviceCapabilitiessrcElement: input.hidden-inputtarget: input.hidden-inputtimeStamp: 55778305.905type: "keydown"view: globalwhich: 89__proto__: KeyboardEvent

And the keybinding resolver prints ‘y’ when I press the z key

It seems Atom can’t get the locale or keyboard settings from Linux


#4

I’ve got a colleague who just ran Atom and he’s got the correct qwertz keyboard layout…
So it seems it’s on my account settings that something must be different, but I compared the env and set commands output and everything seems fine. Same for the locale output


#5

No-one seems to be able to help me, but I found something, will keep you inform in case someone faces the same situation :wink:

Issue is definitely not Atom related, same wrong keyboard if I run a simple xterm, it comes from the way I display these apps, I connect to the server with putty, and use Xming as x11 server, and the issue is there, found that in the logs :

(–) 8 mouse buttons found
(–) Setting autorepeat to delay=500, rate=31
(–) winConfigKeyboard - Layout: “0000100C” (0000100c)
(–) Using preset keyboard for “French (Switzerland)” (100c), type “4”
(EE) Couldn’t open compiled keymap file C:\Users<user>\AppData\Local\Temp\server-0.xkm
(WW) Couldn’t load XKB keymap, falling back to pre-XKB keymap

Trying to find the correct keymap now


#6

Issue came from a bad installation I guess, after reinstalling Xming with non-US keyboards option set, everything is fine.