Keyboard "equal" doesn't work


#1

I’m new to atom - using it a month. I customized a bit - no italic comment font.
when I need a “=”, I copy the symbol with ^c ^v, because the editor doesn’t reacts to “equal key”. Windows 8.1, Lithuanian keyboard. If I switch to Russian keyboard, I have my “=” back. The “=” works fine with every other text field on my system, but atom editor.
Have read a lot of atom discussions and didn’t find anything useful yet. I don’t understand most. Very often some features are explained what happens when some configuration commands customized, but there is no explanation where to find these lines - file and folder.


#2

Welcome to Atom!
There is a FAQ post for the issue your are likely facing I'm using an international keyboard and keys that use AltGr or Ctrl+Alt aren't working

If you need any further help don’t hesitate to ask!


#3

Thank you for response. The problem not solved, however.

  1. My Right-Alt works good, no problem.
  2. I installed the keyboard-layout package. Reading the manual:
    "Usage
    Inside Atom’s packages management, click Settings, and … "
    I don’t see any “settings” there. Please, find the illustration:
    http://i66.tinypic.com/2060xe.jpg

#4

Did you restart Atom after installing the package?


#5

Reloading Atom will make the Settings button appear. You can also click anywhere in that box (except for the buttons and the title) and you will go to a screen with more details about the package as well as its settings options (you don’t need to reload Atom for this to work).


#6

“=” an “”& are working perfect now. After automatic CLI update to 2.10.3