Keybindings - cannot override Ctrl-Alt-F


#1

Hi there,

I am using national keyboard layout so we use keybindings for writing some special characters. Problem is that Atom uses theese keybindings to provide various shortcuts. I edit my keymap.cson file to override this behaviour. I am quite successfull for most of my keybindings but there is one I am still not able to override. Ctrl-Alt-F we use for [ symbol. When I use this keybinding the character is written but the ediotor also opens “Find in current buffer” window.

Here is my keymap.cson:

'.platform-win32 atom-text-editor':
  'ctrl-alt-f' : 'native!'
  'ctrl-alt-g' : 'native!'
  'ctrl-alt-,' : 'native!'
  'ctrl-alt-.' : 'native!'
  'ctrl-alt-b' : 'native!'
  'ctrl-alt-n' : 'native!'

'atom-workspace atom-text-editor:not([mini])':
  'ctrl-alt-f': 'native!'

'.platform-win32, .platform-linux':
  'ctrl-alt-f': 'native!'

'atom-text-editor':
  'ctrl-alt-f': 'native!'

Can someone help me? It is really annoying.

Thanks in advance.


#2

Noone knows?


#3

Have you tried using the Keybinding Resolver (Cmd+. on OS X and Ctrl+. on other platforms)? It will show you what key Atom saw you press and the command that was triggered because of it.


#4

I’m having the same issue with the following

'atom-workspace atom-text-editor:not([mini])':
'cmd-D': 'editor:duplicate-lines'

'atom-text-editor:not([mini])':
'shift-cmd-D': 'editor:delete-line'

The Keybinding Resolver didn’t help. In the image below, you can see it’s totally ignoring the binding I requested.