Key binding to bring up Setting?


#1

I’ve overridden ctrl-, and ctrl-. for some back and forth actions. Now I have to bring up Settings using the file menu. Is there a key binding for Settings I can change? I typed “settings” into the keybindings search box and got nothing.


#2

That’s strange … because this is what I see:

I see the same thing even after I explicitly unset Cmd+, in my keymap.cson:

'.platform-darwin':
  'cmd-,': '!unset'

But, if you bring up the Keybinding Resolver you can see everything that has been mapped to the keys you press, even the overridden ones:

The highlighted one is the one that is ultimately executed.


#3

Hmm. I don’t see how anything could conflict with the search but I definitely got nothing.

I’m a newbie to Atom (started yesterday) so I’m not sure when something is actually wrong. For example, right now when I type ctrl-, the resolver shows the keybindings for …resolver:toggle itself. This may be expected but it’s a wtf to me.

In any case you’ve given me the info I need to put the bindings in my personal file.

Thanks again, sorry for all the questions.

edit: I’m on windows, could that have something to do with it? I notice you have platform-darwin.


#4

I don’t either, so this is the part where I typically ask: “Have you followed the steps in the Debugging document?” And can you supply the following information?

  1. Which version of Atom are you running?
  2. What OS and version are you on?
  3. Can you reproduce the issue with atom --safe?

Because I know from your previous questions that you’re on Windows, I’ll also ask: Are you building yourself or installing? If installing, which installation method did you use?

If you can provide a screenshot or GIF of what you see, that is also helpful.


#5

Are you sure you’re not typing Ctrl+Period?


#6

Duh once again. In that one test I hit the wrong key. When I hit the right key I see the original settings binding with my override. This is enough info to put the binding in my file.

However, I still can’t see the setting binding in the keybindings pane. If I search for settings I get nothing. If I search for ctrl-, I see my binding and nothing else As I said this isn’t a show-stopper now but it should be entered as an issue somewhere. I’d do it if I knew where to post it.

Thanks again …


#7

I’d like to help you with this. I need to know a little more about what the real issue is though. Can you take a screenshot of the exact behavior? It seems that the Keybinding Resolver is finding things correctly, but that the Settings View is not. If this is the case, then you can file an issue on the Settings View package here:

I’d really appreciate it if you could answer my previous questions though so I can help you give the Atom team as much information as possible so that the bug can be quickly resolved.

You’re welcome! We all went through the learning experience … I just did it before you :grinning:


#8

Here is what happens when I search for settings …

At this point the original ctrl-, works but not when in an editor pane, only when I click in the tree-view first.

Then I add this code …

'.platform-win32':
     'ctrl-shift-,':     'settings-view:open'

Which gave this when I searched again …

After I put in this ctrl-shift-, key behavior did not change. Ctrl-, works but not ctrl-shift-, This gives me the impression that the settings key does not use the keybinding files at all.


Which version of Atom are you running?

— 0.115.0

What OS and version are you on?

— win 8.0

Can you reproduce the issue with atom --safe?

— I can’t use --safe because all packages including default ones are suppressed and I can’t try anything. This is outlined in another issue.

…which installation method did you use?

— I installed using chocolately.


This is complex and I’m brand new to atom. I don’t think I’m competent enough yet to file a proper bug report. Also I have two or three other bugs I’m chasing, any of which may be my problem.


FWIW: These bugs don’t bother me. So far I can work around them and Atom is something I’ve dreamed of for a long time. I plan on writing my own packages when I can.


#9

I disagree, this is a great bug report!

@batjko You run Windows, right? Can you reproduce this? Specifically searching for settings in the Keybinding view in the Settings View?


#10

BTW: I wiped atom from my pc and installed it fresh with chocolatey. The problem was there.


#11

Strangely enough I can confirm that the keybindings view does not have settings in it on my Win8 build (not from chocolatey):

However, Ctrl-, works to actually open it.
Note the binding the resolver actually identifies! This is the default, I haven’t overwritten it:


#12

I’ve opened issue #2968 for the missing entry in the list.

Doesn’t solve your problem @mark_hahn, but at least now you know you’re not crazy.

I would recommend finding your settings-view.json (will probably be located somewhere else than mine as chocolatey installs atom in different folders) and check out what it says about your changed key bindings on .platform-win32 maybe?