Key binding 'ctrl-shift-,' not working


#1

First, I tried to map:

'body':
  'ctrl-shift-,': 'application:show-settings'

'.platform-win32, .platform-linux':
  'ctrl-shift-,': 'settings-view:open'

It didn’t work. I made sure the file was saved, restarted atom, still not working.

This works fine, so it’s not the command itself:

'body':
  'ctrl-;': 'application:show-settings'

'.platform-win32, .platform-linux':
  'ctrl-;': 'settings-view:open'

For good measure, I also tried this:

'body':
  'ctrl-shift-,': 'core:close'

No avail. I just can’t get 'ctrl-shift-,' to work. Does anyone know what the issue could be?


#2

Have you opened the Keybinding Resolver to see what keys Atom thinks you’re pressing when you type Ctrl-Shift-,?

I just tested it and the Keybinding Resolver shows that it sees Ctrl-<. After a couple tries, this is what worked for me:

'body':
  'ctrl-<': 'settings-view:open'

#3

Thanks so much! I’m pretty new, so I didn’t know about the Keybinding Resolver. I was able to get it working with:

'body':
  'ctrl-<': 'application:show-settings'

'.platform-win32':
  'ctrl-<': 'settings-view:open'

#4

I don’t think you need the application:show-settings one. Like I said, just the settings-view:open command was sufficient.


#5

Sure, I’ll try it without the 'settings-view:open', I just threw it in there because it was in the keymapping for 'ctrl-,' when I searched.