Keep Distractions to a bare minimum?


#1

If anyone has ever worked with UWP there are great to use as the Windows API allows you to view the window full screen without distractions; without even having the title bar which makes you feel as though your not just working in another program; you literally become immersed into the program you’re using for the duration you’re in the program.

Is there such an option for Atom to hide the title bar and have the menu bar larger; unless modifying the CSS rules for Atom answers this question ?


#2

The answer is zen.


#3

I restarted Atom after installing zen. The usage guide mentions Shift-F11 to go into no distraction mode but the title bar is still visible ?


#4

Apparently it doesn’t hide the title bar.

Edit: Corrected by @danPadric!


#5

You mean like this?

Have a look at all the configuration settings available in the package. To remove the top menu bar: View -> toggle menu bar.


#6

Yes, that is the result I wanted; although I think another package is conflicting :frowning:


#7

What seems to be getting in the way?


#8

Turns out another package has ceased to work :frowning:


#9

Which one?


#10

SVG-Preview. It was working, abruptly it doesn’t work; I’ve restarted Atom five times, doesn’t start.


#11

I don’t know enough about that package to troubleshoot it. What happens if you uninstall it and then install it again?


#12

I uninstalled the package and re-installed, same result. Can you install the SVG preview package and set the syntax highlighting to HTML within Atom and see if you can preview this shape ?

<svg>
<style>
/*Style */
 /* Old browsers */;}
</style>
<path id="u.beakshape_1_" class="st2" d="M130.9,68.4c-7.8-5.4-9.2-5.4-17-10.8c-2.3-3-8.9-6.1-14.5-8.3s-9.3,0.8-16.8,4
  c-1.4-2.1,10.5-14,11.1-18.8s0.7-5.5-5-6c-5.7-0.5-17,4.7-51.1,21.8C27,55.8,11.1,65.4,7,72.2c-3.5,5.8,23.1,3.1,43.8-1.8
  C73.1,65.1,102.7,69.4,130.9,68.4z"/>
</svg>

#13

It doesn’t work for me when the grammar is set to HTML, but it does work when the grammar is set to XML, which is the default for SVG files for me.


#14

Thanks it works :slight_smile: