Just installed atom on Debian and on opening editor displays a blank window


#1

Hi all,

Not the first time installing atom on Debian but for some strange reason this time it does not work?

  1. New Debian install
  2. Downloaded atom package and run dpkg -i
  3. run apt-get install -f to get dependencies
  4. tried to open atom and like i said not displaying anything

As far as i can tell atom is running because deleting .atom recreates it, but obviously it is not running correctly?

Any advice?


Hardly anything works (1.21 beta) after install
#2

What happens when you start Atom with atom --safe?


#3

Exactly the same thing unfortunately - it’s like the contents of the window cannot be rendered?


#4

Fixed it!

Turns out Atom will not render correctly if 3d acceleration is turned on inside virtualbox.

Not sure which piece of software is the culprit though.

Thanks for the help!


#5

That is, sadly, a known bug in virtualbox. You can start atom with --disable-gpu to get it to bypass the 3D acceleration, or just turn off acceleration. Problem with the latter solution is it makes VirtualBox slooooow.