Julia not appearing in package list


#1

The language Julia does not appear in my package list.

Does anyone know how to get it to appear or why it might be missing?

The julia related packages I have installed are:
uber-juno
language-julia


Julia is not available from Atom!
#2

If language-julia doesn’t appear under Settings -> Packages, then it isn’t installed.


#3

Okay - I just checked my installed package list under “Settings” and language-julia version 0.15.0 says it is installed but it still doesn’t show on my package list.

Any thought son how I can resolve this and get it to show up?


#4

What is this “package list” you are talking about, if not the list in settings?


#5

Sorry for being unclear.

So if I go to File --> Settings --> Packages --> Community Packages --> In this list I can find language-julia and it says it is installed.

The “other” list is, instead of the File drop down menu at the top left of the editor window, if you pan farther to the right there is a “Packages” drop down menu. language-julia is not listed in that drop down.


#6

A package only appears in that drop down if it offers a menu item there. To manually select the Julia grammar, open Grammar Selector: Show in the command palette, or use the shortcut ctrl-shift-L. Search for Julia, and it should be there. However, the highlighting should be applied automatically. Is this not the case?


#7

Yes – Atom appears to know I am using the Julia language when I have a .jl script open. Something seems to be wrong with how Juno is installed though. I am trying to follow the directions here http://docs.junolab.org/latest/man/basic_usage.html and the first step is go to Packages --> Julia --> Console. Well, Julia isn’t even listed under packages (as I described above) so I’m trying to figure out what went wrong.


#8

I just installed uber-juno and allowed it to install everything it wanted (which is what I would consider unwanted behaviour), and it appears under the packages tab in the menu bar. The entry was titled Julia.


#9

Yes! That is what it should look like. Perhaps I should do a total reinstall of all julia related packages? Or just a clean install of atom?


#10

Maybe try uninstalling uber-juno first, restarting Atom, and installing it again.

Just wondering, did it make a toolbar on the left hand side of your screen? Because it looks like the open console command is there as well.


#11

So I just uninstalled, restarted atom, and reinstalled. Didn’t make a difference.

I don’t see any toolbar, just the file/project structure on the left of the screen. It did add a terminal though that cannot be typed in. This terminal is different then the one added by the termination package.


#12

In the package list (in Settings) are all of the following packages present?

'tool-bar'
'indent-detective'
'latex-completions'
'language-julia'
'language-markdown'
'ink'
'julia-client'

Edit: You need to go to uber-juno settings and untick the only setting there. Upon next Atom restart, it should attempt to install the packages I just listed.


#13

What happens when you try ctrl+j ctrl+o/cmd+j cmd+o? The documentation you’ve linked says that’s the keybinding for julia-client:open-console.

In fact, I found something funny. All of the menu items for the julia-client package are defined here, but I don’t see any menu bar items. So if @Aerijo is seeing a Packages -> Julia entry, where is it coming from?


#14

Cool! That fixed it, it all appears to be displaying and working as intended, at least using the interactive environment (REPL).

Still am getting a weird error when I try to compile and run a Julia script. For example, I’ve saved a file, JuliaTest.jl that just contains a = "Hello World" but when I left and click and do compile and run it gives the following error: The error was thrown from the gpp-compiler package. This issue has already been reported.

Why is Atom trying to use my c++ compiler to compile a Julia script? (might be a stupid question, I’m a noob)


#15

I found uber-juno to download a bunch of other packages without asking. It could be from any one of them.


#16

Bam, found it. It is indeed julia-client, and it’s determined by a config setting that uber-juno configures on install.

@RedBowTie You should be able to get the Julia menu by going to Settings -> Packages, clicking on the julia-client card, and looking for a setting to enable the menu. Then restart Atom.


#17

I think it is working properly now.

Thank you both very much for your time and patience with this :grinning:


#20

I noticed that julia-client did not have an icon or settings attached to it and then uninstalled and reinstalled it. It worked. Julia is now available from within Atom! Many thanks!