JSX in JS files with no indentation on Windows 10


#1

Hi,
I’m using Atom for 10 months. I’m new to this forum.
I have a few problems with my Atom.

  1. Many times Atom does not create an automatiic indentation. For example a

    tag inside a

    tag will appear on the same column, even when I press enter after the opening
    tab.
  2. It will show 2 sapce tabs, even though I defined it to have 3 spaces in File->Config.
    Any suggestions?
    Sincerely,
    Ben

JSX in JS files with no indentation
#2

Hello Ben. Welcome.

With which programming language do you see these occurrences?

As for #2 - program language can override the indentation spacing. Check the settings linked to the program languages you are using.

Cheers.


#3

Before posting code, you should highlight each tag and press the </> button above the editor to mark it as code. This is especially relevant for HTML, as you can see.


#4

This occurs mostly with JSX (React). Even though I have some react packages installed. Any suggestions?
Sorry about the delay.