It doesn't work with snippets in Markdown file


#1

In my own snippets.cson , I create a new snippet :

'.source.md':

  'Read More':
    'prefix': 'more'
    'body': '<!--more-->\n'

But when I input more, it doesn’t give me advice. And the file blacklist is default.

I don’t know this problem is belong which package - autocomplete-plus or autocomplete-snippets


#2

Can you try changing the language scope to .source.gfm, so:

'.source.gfm':
  'Read More':
    'prefix': 'more'
    'body': '<!--more-->\n'

And then make sure the file you’re working on is set to GitHub Markdown? You can either save it as a .md file or set the language using grammar selector.


#3

Thanks for your reply!

But it still doesn’t work.
This my snippets:

'.source.md, .source.gfm':

  'Read More':
    'prefix': 'more'
    'body': '<!--more-->\n'

The file is.md or .gfm. The grammar is Markdown.

It is confused that snippets of other language scope (like C++) are fine.

But in my autocomplete-plus package settings, the Scope Blacklist is empty, and the Built-In Provider Blacklist is .source.txt, the File Blacklist is .txt.

There is any setting in autocomplete-snippets package.


#4

I find the solution .
we should change .source.md to .text.md