Issues with installing packs. Ideas?


#1

I’ve just installed Atom on my Windows8.1 computer, and while I love it, I’m having trouble installing packages. The weird part is that it worked before, but (after having to reinstall everything it due to antivirus panic, long story) I can’t install the packages again. I’m not sure why, but not one package that’s not pre-built will download. Two of the many packages I tried are Emmett and color-picker.

Do I need to install something to fix it or something? I know it worked before I reset my computer…

Here’s a screenshot of the error message.


#2

Where do you have atom installed? Maybe your user does not have write access in that location.
If you are using the integrated package manager try to run Atom as administrator first. You know, right click, run as administrator.


#3

Do you have a git in your path? Seems like that is a problem according to error message.


#4

@Istar_Eldritch, I presume “program files”? I just ran the auto-installer. Let me check… Actually, it’s in “C:\Users\Me\AppData\Local\atom\app-0.176.0”. Weird, isn’t that for saving settings? Anyway, this account is the only one, so I think I’m supposed to have all the administrator rights. I will try again under admin mode tho… Nope, denied again.

@Trudko, I just installed Git, but I’m not sure what it means by the path part. Anyway, tried again, failed again.

So, I guess the answer is to put Git in it’s path? What’s that mean? Do I need to install another copy of Git to the Atom directory?


#5

Type git --version and see if it responds. If it does then it “is in your path”.


#6

My bad. Didn’t saw the error log. Obviously is what @Trudko points.

The path are the defaults routes the OS uses to find the binaries. So when you use the git command it will search in the path for the git executable. If git is not in the path then it won’t work.

In windows git is usually installed in C:\Program Files (x86)\Git.

Check where’s you git installation, after that to add it to the path the easy way is using the GUI. Follow this tutorial http://www.computerhope.com/issues/ch000549.htm

Basically you have to add the Git binary route to the Path variable. The binary usually is inside the bin folder located inside the installation path. So in the most common case you should add C:\Program Files (x86)\Git\bin`

After this you might have to reboot.


#7

@mark_hahn I wasn’t sure what I was supposed to type it into… Command prompt doesn’t understand that. Was that where I was supposed to put it? Git Bash answers it though, not that I know what to do with it.

@Istar_Eldritch I’m trying to understand what you guys are saying, but I don’t. Consider me a n00b, but what does SO stand for? What am I supposed to change, something in Control Panel or Atom settings?


#8

Then it is not in your path. Programs in your path can be accessed from the command line. The installation process uses the path to find git. You should google “command line path”.

There have been requests made (by me) to have git automatically installed and put in your path when Atom is installed. But that doesn’t happen now.


#9

Oooooooh, I see what’s going on now. Thanks guys!

Okay, to be clear, I’m going to use Istar’s tutorial link, use the path to the CMD folder from Git to tell Windows how to work with Git, and if that happens then Atom starts using Git to grab pack updates. Is that right? Seeing that there’s a way to undo it, I’m going to go ahead. Thanks again everyone for all the help! :smiley:

EDIT: It works now, and I didn’t even need to reboot! Sweet! Thanks again guys!


#10

Since everything is working for you, I’m going to close this in 24 hours unless there are more questions?


#11

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.