Issues Installing on Fedora


#1

I’m trying to get Atom running on Fedora. i went through the initial install and now I get some error. If anyone could give me some direction to move forward that would be great.

When I run “atom” I get, what looks like an empty browser.

When I run “apm” I get:

module.js:356
Module._extensions[extension](this, filename);
^
Error: /lib64/libc.so.6: version `GLIBC_2.17’ not found (required by /usr/local/share/atom/resources/app/apm/node_modules/atom-package-manager/node_modules/git-utils/build/Release/git.node)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object. (/usr/local/share/atom/resources/app/apm/node_modules/atom-package-manager/node_modules/git-utils/lib/git.js:8:16)
at Object. (/usr/local/share/atom/resources/app/apm/node_modules/atom-package-manager/node_modules/git-utils/lib/git.js:346:4)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)


ERROR: I got an error while building. Please help!
#2

What version of glibc do you have installed? http://freeadhocudf.org/documentation_english/dok_eng_howto_glibc.html


#3

It looks like I’m using 2.15. Any idea if Atom works with 2.15 or how to point it to use this version?


#4

Sorry, no idea on both questions. Also, I’ve never used Fedora so I can’t be much help with specifics. However, I assume 2.17 is required for some reason. If rpm doesn’t have an update for you, you might have to update Fedora or build from source. This seems like a relavant SO question: http://stackoverflow.com/questions/17388612/how-to-update-glibc-2-17-in-centos.


#5

Thanks for the suggestion. This is a work computer and for now I need to stay in this environment.

Does anyone else know if Glibc 2.17 is required for atom? or is there a method to use 2.15?


#6

It might not be Atom that requires GLIBC 2.17. It might be git.node.

I noticed in another issue that Debdut is having a problem with 2.15 and libgcrypt.