Issue with: self signed certificate in certificate chain


#1

Hi guys,

Quick question - I’m trying to install some packages but am running into the error in the title:

I have found this bit here and have tried disabling the SSL.

When I do that I get a different message that reads:

“Peer disconnected after first handshake message: Possibly SSL/TLS Protocol level is too low or unsupported on the server”

This is kicked off by a piece of hardware we use here at our organization.

I have gotten Git, NPM and others to work fine by specifying them to use a CAFile.

I tried setting the CAFile in the settings - but even by specifying the same CAFile (which works for git and npm); I get the ‘self signed certificate in certificate chain’ error.

I’m at a loss on how to go further, or where to look to solve this because the recommended method doesn’t work, specifying a CAFile doesn’t appear to work… any other ideas?


#2

I have a similiar issue. I have configured the certificated which is used by the proxy as the cafile for npm:
$npm config list
cafile = “/usr/local/share/ca-certificates/bluecoat.crt”

Since apm says it’s just a wrapper for npm I did the same for apm:

$apm config list
cafile = “/usr/local/share/ca-certificates/bluecoat.crt”

However apm fails to work:

$apm search groovy
unable to verify the first certificate

Of course setting strict-ssl to false works, but this is not how SSL is meant to be.