Issue with keybindings


#1

Hi all,
I’m trying to customize my keybindings to be vim-like. I want to bind cmd-j to move the cursor up and cmd-k to move it down. However, when I press the command there is a delay and I have to press cmd-j and then j once more for it to move one line up (same for cmd-k).
The following is part of my keymap.cson file:

'atom-workspace atom-text-editor:not([mini])':
    'cmd-j': 'core:move-up'
    'cmd-k': 'core:move-down'

The reason I have it under 'atom-workspace atom-text-editor:not([mini])' is because it doesn’t bind if I have the commands under 'atom-text-editor': or anywhere else.

Also, if I move down the page using cmd-k and then press / it inserts / one line below (not the case for cmd-j).

The second issue I’m having is the fact that cmd-k * is bound to various other actions and I wanted to disable them.


#2

Sounds like the cmd-* version of this problem:


#3

If you want Atom’s keybindings to be vim-like, have you tried the vim-mode or vim-mode-plus packages?


#4

Thanks for the information on vim-mode-plus. I’ve moved from vim-mode to vim-mode-plus. However, the problem that andy9775 and I had was about moving around insertion point. What vim-mode and vim-mode-plus enable us to do is moving around cursor in escaped mode. That said, I already solved the problem by disabling all keybindings that were blocking the way and considering cascade order. I encourage everyone that has the same problem to go check my post How to fix the one step delay for Atom text editor?.


#5

Thanks @deprint and @sumo, I’ll give those a try. I was hoping that I didn’t have to go through and remap everything.