Issue with autocomplete


#1

Hey guys,

I’m new to Atom and am experiencing a weird problem when using the autocomplete package.

When I am typing some code the autocomplete box shows up for a second but then disappears before I have a chance to select anything. When I press Ctrl + Space the box appears and I am able to select an option using the arrow keys but ideally I would just like to be able to use it without having to press Ctrl + Space each time. I’ve tried disabling and re-enabling the package but this doesn’t seem to work.

I am running the latest version of Atom (v1.0.2).

The autocomplete packages I have are:

autocomplete-html
autocomplete-css
autocomplete-plus
autocomplete-atom-api

From what I understand autocomplete-plus overrides the other ones.

Any help is greatly appreciated.

Kind Regards,

Russell


#2

The autocomplete-plus package is a prerequisite of the other ones. It doesn’t override them. The other three packages are autocomplete providers, they provide autocomplete suggestions for things.

The default configuration of autocomplete-plus does not require you to press Ctrl+Space. If you are in a situation where a provider has autocomplete suggestions, they will simply show up if you stop typing.

If you’re still having issues, please record a GIF and post it so we can see what’s going on.


#3

Thanks for your reply. How do I go about recording a GIF?


#4

See the Common Questions section here:


#5

I’ve attached the GIF. You can see the box appear and disappear on it’s own accord, then me bring it back up by using the Ctrl + Space combo.


#6

Could you give the following information?

  • Which version of Atom are you using?
  • What OS and version are you running?
  • Do you have Emmet installed?
  • Can you reproduce the issue after completely exiting Atom and restarting using atom --safe?

#7

As mentioned it is v1.0.2 of Atom.
I’m running Mac OS X 10.9.5.
I do have Emmet installed.
The issue does not occur when I run Atom in safe mode.


#8

I suspect that Emmet is the cause of the issue. Can you try disabling Emmet and then restart Atom normally?


#9

Restarted normally with Emmet disabled and there are no issue with the autocorrect. It must be interfering.


#10

UPDATE: I’ve uninstalled Emmet, restarted my computer overnight and am now experiencing the same issues again. So I guess it must be something else interfering.


#11

For anyone else reading I have found the cause of my problem. I had a package installed called atom-html-preview which seemed to be messing the autocomplete package.