Issue when installing a package


#1

I’m trying to install the package git-log, but it encounters an npm error. Here’s the pastebin. I’ve installed several other packages, so what’s the deal? I’m running Atom 0.129.0 on Windows 7. Thanks in advance!


#2

Perhaps related to this:

Or this:


#3

Some time ago I’ve also had the problem that some packages failed to install. Line 128-129 of your error log look familiar and seem to indicate it’s related to node-gyp. I solved it by adding the following 3 directories to my path:
C:\Program Files (x86)\Git\bin\
C:\Program Files (x86)\Git\libexec\git-core\
C:\Program Files\nodejs\node_modules\npm\bin\node-gyp-bin\