Is this a visual studio problem?


#1

Whenever I install some packages, like apm install pdf-view , add--msvs_version=2013 or not, there is always an error like this:

node "C:\Users\chao\AppData\Local\atom\app-0.187.0\resources\app\apm\node_modules\npm\bin\node-gyp-bin\\..\..\node_modules\node-gyp\bin\node-gyp.js" rebuild
�ڴ˽������һ������һ����Ŀ����Ҫ���ò������ɣ������ӡ�/m�����ء�
C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.Cpp.Platform.targets(64,5): error MSB8020: The build tools for Visual Studio 2012 (Platform Toolset = 'v110') cannot be found. To build using the v110 build tools, please install Visual Studio 2012 build tools.  Alternatively, you may upgrade to the current Visual Studio tools by selecting the Project menu or right-click the solution, and then selecting "Upgrade Solution...". [C:\Users\chao\AppData\Local\Temp\apm-install-dir-115225-2880-j71ip9\node_modules\pdf-view\node_modules\pathwatcher\node_modules\runas\build\runas.vcxproj]

gypnpm ERR! Windows_NT 6.2.9200
npm ERR! argv "C:\\Users\\chao\\AppData\\Local\\atom\\app-0.187.0\\resources\\app\\apm\\bin\\\\node.exe" "C:\\Users\\chao\\AppData\\Local\\atom\\app-0.187.0\\resources\\app\\apm\\node_modules\\npm\\bin\\npm-cli.js" "--globalconfig" "C:\\Users\\chao\\.atom\\.apm\\.apmrc" "--userconfig" "C:\\Users\\chao\\.atom\\.apmrc" "install" "C:\\Users\\chao\\AppData\\Local\\Temp\\d-115225-2880-1obi2lo\\package.tgz" "--target=0.21.0" "--arch=ia32" "--msvs_version=2012"
npm ERR! node v0.10.35
npm ERR! npm  v2.5.1
npm ERR! code ELIFECYCLE

npm ERR! runas@2.0.0 install: `node-gyp rebuild`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the runas@2.0.0 install script 'node-gyp rebuild'.
npm ERR! This is most likely a problem with the runas package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node-gyp rebuild
npm ERR! You can get their info via:
npm ERR!     npm owner ls runas
npm ERR! There is likely additional logging output above.`

my system is win 8.1 x64, io.js 1.61 x64, python 2.7, vs 2013 ce with update 4, there are both vs2012 and vs2013 command prompt, is this cause this problem?