Is there any way to disable smartquotes?


#1

Greetings everyone.

I just recently had installed Atom, and I like it and all, but I get extremely irked at the “smartquotes” as I’d like to call them.

See, when I type quotes, it auto-makes another quote after the letter I type, so even though I’m a fluent typer of 75 WPM I need to slow down and reach ALL the way to the right side of my keyboard and press the down button.

I also end up forgetting it has that feature half the time, and screw up my code, which happens often.

If there’s any feature to disable this… feature, please notify me, because I’d like on my code exactly what I typed, you know?

If atom hasn’t implemented a feature like this, then I don’t know what to say… I mean, this is an essential thing for me.

The editor is cool, really, just disappointed about this.

Thank you for your time.


#2

Oops guys, I meant the “side arrow” not the down button…


#3

Look at bracket-matcher settings.


#4

I’ve heard that twice.

However, as I’m in the Atom client, I can press File, and I assume the set of setting is the one in there. I click “Settings”, so we’re in File>Settings, but from there I don’t see any “bracket-matcher” setting.

I’m very confused.


#5

In Atom, the settings is a pane itself. cmd-, may open it for you, but I’m guessing you are able to open it already.

There are tabs along the left hand edge of the settings pane, that say “core”, “editor”, etc. You need to click the “packages” tab, and search for bracket matcher. Click the bracket matcher card, and scroll down to the right setting. It should be the second one.


#6

There really does need to be a better way for people to find settings than 1) figure out which package implements it, 2) go to that package’s settings.

Not sure what a solution would be, but we should have it on the radar.