Is there any proxy settings?


#42

I’m unable to install any packages or themes behind the proxy environment. It’s throwing “connect ETIMEDOUT” error. I’ve updated my proxy settings but still haven’t gotten rid of that error. Am I missing anything? Please let me know.

Error:

Result for apm config get https-proxy and apm config list :

Thanks,
Avinash.


#43

Can someone please help me with this?


#44

Atom really doesn’t seem very mature in the current state. This sort of problem is usually hammered out by the first round of users. Anyway just wanted to post that the path
C:\ProgramData\chocolatey\lib\Atom.0.127.0\tools\Atom\resources\app\apm\node_modules\atom-package-manage.apmrc

chocolatey - sure doesn’t look right. And isn’t on any of my windows boxes. Perhaps this is was the original name of the beta?


#45

Chocolatey was the first package manager used to install Atom on windows. It sucked and was buggy. They switched the squirrel which is better.

Where did you hear about chocolatey? It should be ancient news. Make sure you install the latest version of atom from the atom.io home page.


#46

I’m replying to the suggested fix. The file path contains that word, I’ve also tried the hidden files in the user directory, and the apm config set proxy commands all to no avail.


#47

Then you are working on a very old install. You should upgrade to the latest.


#48

I don’t have a proxy, but I am behind a corporate SSL sniffing firewall.
Try modifying these two files (or creating them if they do not exist):

%userprofile%\.npmrc
https-proxy=xxxxx
http-proxy=xxxxx
strict-ssl=false

%userprofile%\.atom\.apmrc
https-proxy=xxxxx
http-proxy=xxxxx
strict-ssl=false

Hopefully that will work. You will really have an uphill battle with this as the culture around atom just doesn’t lead to a focus on fixing issues and improving the experience of users in corporate environments.


#49

I think this is a particularly overbroad statement. I work in a corporate environment (which is not GitHub) using Atom every day and haven’t had an issue with the community helping me with issues. It is true that my corporate environment does not employ proxies or firewalls that require the kinds of workarounds that are being discussed here. I just don’t feel that generalizing from “people haven’t helped me as much as I want with my proxy or firewall issues” to “Atom culture doesn’t respect corporate users” is valid.


#50

I should mention that I’m in Windows 7 land here. In Linux land I don’t need to set the proxy at the application level for unrelated networking reasons. There was no file nor environment variable that I could set to make this work. What did eventually work was to
apm config set proxy "http://xxx.xx.xx.xx:xxxx"
apm config set https_proxy "http://XX.xx.xx.xx:xxxx"
!! Note after the port there is not a trailing slash “/” !!
The problem with this solution is that it isn’t compatible with the auto configuration proxy. It should just take the settings from the operating system (and still have a gui to override that setting locally to the progam)


#51

Try _ (not “-”) ?


#52

Thotty,

Your instructions also are correct for windows 7 proxy:

apm config set proxy "http://user:pass@host:port" apm config set https_proxy “http://user:pass@host:port”


#53

I use to work under a corporate SSL sniffing firewall and a home network too. So during this network switching I frequently need to add and Delete these proxy settings daily.

Is there any way for APM(and NPM) to check for the proxy connection first, if it is found then go for the proxy otherwise go for the normal settings. This way I won’t have to manually Add / Delete these proxies everyday.


#54

There’s no method built-in, no. But it shouldn’t be too complicated to perhaps write a wrapper script that launched Atom or apm with or without the proxy stuff by copying files or editing the .apmrc.


#55

I’m getting this error now when trying to connect through my proxy.

tunneling socket could not be established, cause=11696:error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol:openssl\ssl\s23_clnt.c:782:

Don’t know what this could be. All I can understand is it doesn’t know the SSL protocol we’re using at work.

Any feedback would be greatly appreciated!

Edit
Actually I did this and got further.
https-proxy=https://domain\username:pass@proxyaddress:port
And I get this error
tunneling socket could not be established, cause=connect ETIMEDOUT
I see others are having the same issue. Any word on this being fixed or how to troubleshoot?


#56

Same problems here, downloading the package list works after the apm proxy settings, but installing fails with the know Parse Error.

+1 for propper proxy support.


#57

Not sure if this will work for you, but cntlm (http://cntlm.sourceforge.net/) has always worked for me. I work behind a firewall and proxy and it used to cause me no end of grief when trying to use an app that needs to touch the internet. Sometimes apps could figure out the proxy, but then when I would connect via VPN it would get hosed up or when they would switch auto-configuration scripts it would get hosed up. Then I found cntlm and all of those troubles are a thing of the past. Hit the Sourceforge link and give it a try. Once configured I think (hope) your proxy issues will be resolved.


#58

Alright I’ll give it a try and report back. Thanks!

UPDATE
Fixed my issue with the CNTLM program that darrylluther told me about. Works like a charm. After messing around with it I got it working and I’m happy! haha. Still wish we had better integration of proxy settings in atom but probably won’t happen.


#59

It took me a long while to get this to work as I’m behind a pretty hefty proxy.

Here’s how I had to do it.
ENVIONRMENT: WIndows 7

  • Browse to your .atom directory, for me it was under (C:\Users<meow>.atom
  • Create a new file named ‘.apmrc’
  • Open and add in:
    https-proxy=http://USERNAME:PASSWORD@domain:port

(If your password has “@” symbols then you’ll need to enter them under a different encoding= “%40”)


#60

Am stuck behind Z-Scaler in my corporate environment. This is the simplest solution in my case:

apm config set strict-ssl false --global

Not super-secure admittedly, but convenient… that’s always the trade-off though.


#61

go here https://github.com/atom/apm#behind-a-firewall and read the confit setting