Is there any proxy settings?


There’s no method built-in, no. But it shouldn’t be too complicated to perhaps write a wrapper script that launched Atom or apm with or without the proxy stuff by copying files or editing the .apmrc.


I’m getting this error now when trying to connect through my proxy.

tunneling socket could not be established, cause=11696:error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol:openssl\ssl\s23_clnt.c:782:

Don’t know what this could be. All I can understand is it doesn’t know the SSL protocol we’re using at work.

Any feedback would be greatly appreciated!

Actually I did this and got further.
And I get this error
tunneling socket could not be established, cause=connect ETIMEDOUT
I see others are having the same issue. Any word on this being fixed or how to troubleshoot?


Same problems here, downloading the package list works after the apm proxy settings, but installing fails with the know Parse Error.

+1 for propper proxy support.


Not sure if this will work for you, but cntlm ( has always worked for me. I work behind a firewall and proxy and it used to cause me no end of grief when trying to use an app that needs to touch the internet. Sometimes apps could figure out the proxy, but then when I would connect via VPN it would get hosed up or when they would switch auto-configuration scripts it would get hosed up. Then I found cntlm and all of those troubles are a thing of the past. Hit the Sourceforge link and give it a try. Once configured I think (hope) your proxy issues will be resolved.


Alright I’ll give it a try and report back. Thanks!

Fixed my issue with the CNTLM program that darrylluther told me about. Works like a charm. After messing around with it I got it working and I’m happy! haha. Still wish we had better integration of proxy settings in atom but probably won’t happen.


It took me a long while to get this to work as I’m behind a pretty hefty proxy.

Here’s how I had to do it.

  • Browse to your .atom directory, for me it was under (C:\Users<meow>.atom
  • Create a new file named ‘.apmrc’
  • Open and add in:

(If your password has “@” symbols then you’ll need to enter them under a different encoding= “%40”)


Am stuck behind Z-Scaler in my corporate environment. This is the simplest solution in my case:

apm config set strict-ssl false --global

Not super-secure admittedly, but convenient… that’s always the trade-off though.


go here and read the confit setting


Could you please elaborate on your CNTLM configuration ? I set it up and it works for wget but not with apm :
Request for package information failed: tunneling socket could not be established, cause=getaddrinfo ENOTFOUND (5 attempts) (ECONNRESET)


For basic configuration, you only need to set this configuration

Username yourusername
Domain yourdomain
Password yourpassword
Proxy yourproxy


I have put the proxy settings ( HTTP_PROXY and HTTPS_PROXY ) in .bash_profile and restarted terminal. Then tried ATOM and it worked.


On Linux and with proxychains4, to install a package via proxy, following would do:

proxychains4 apm install atom-beautify


Thanks bro… it’s working just fine


This works fine in the last version {1.12.3}

$ apm config set https-proxy https://user:password@domain:port


Is there an apm log I can check to see what it’s trying to connect to?

I’m behind a Websense proxy and even with correct proxy settings apm is failing with…

“Peer disconnected after first handshake message: Possibly SSL/TLS Protocol level is too low or unsupported on the server”

Cursory research suggests the Websense proxy may not be configured to support the TLS protocol used by whatever apm is trying to connect to, but the HTML error message displayed by apm doesn’t even indicate what url it is trying to connect to that has failed, which makes it impossible to progress towards a solution.


On Windows 7 I did the following to make it work,

Inside the atom.cmd file located under ~\AppData\Local\atom\bin i added

@echo off
set HTTP_PROXY=http://:
"%~dp0…\app-1.12.7\resources\cli\atom.cmd" %*

Then I launched atom using this cmd


The .apmrc file already exists in my Win7 installation. After adding those lines, saving the file and restarting Atom, the .apmrc file is overwritten back to its default state (the lines are removed).


I have also been using CNTLM for authenticating through our corporate proxy for installing npm packages, among other things. I’m currently writing up my experience using CNTLM and I won’t go into it here but its pretty straight forward to install and configure.

If, like me you are already using CNTLM for npm then the .apmrc proxy configuration is the same as .npmrc proxy configuration. Basically, create the file C:\Users_username_.atom.apmrc and add your cntlm proxy details

This is how my .apmrc looks in my (now) working configuration.


My cntlm instance lives on my local host and listens on port 3128


If your Username or Password contains any characters that need to be URI encoded, you will need to do that manually.

Here is an example
if your username was Universe\Jonathon.Mckay
your password was P@ssword!
your proxy url was

then your .apmrc configuration would look like this


In Windows 7 I opened the cmd apm config edit
I added a new line proxy=, I didn’t set https-proxy
Restarted Atom and it worked.