Is Paste Broken or am I dumb?


#1

So I am using Atom on windows for the first time and I cannot seem to get Copy and Paste to work. I copy or cut a line of text and when I hit ctrl+v nothing goes in the editor. Any idea if I am doing something wrong?


#2

Have you followed the Debugging guide by any chance?

What’s your atom version?
What does the Key binding resolver (Ctrl - .) show when you press copy and paste combinations?
Any errors reported in the console?


#3

I’m experiencing this as well using 0.125 on windows, copying works as I can paste into other apps, the key binding resolver shows ‘ctrl+v’ matches ‘core:paste’ but then selecting paste from the menu doesn’t work either. If I select text first it disappears when I paste as you’d expect but the clipboard text doesn’t appear. No error appears in console, it simply says windows load time of 6sec, and starting in safe mode doesn’t help either.


#4

Have you changed any config options? Do you have any utility on your OS related to keys? Have you tried it on a different system?


#5

I haven’t changed any config options apart from theme from dark to light, I’ve only just downloaded it. I don’t have any utilities installed related to keys. Pasting works in every other program I’ve tried on my PC.

Pasting does work on a different system, in a virtual machine apart from the ‘desktop.ini’ file I happened to open which I’m guessing is to do with encoding as I can copy and paste the letters I’ve typed in ok but the existing content I can’t and it takes two right arrow key presses to move cursor across 1 character.


#6

Are you on a PC or mac? If PC, did you use chocolatey?


#7

PC, didn’t use chocolatey


#8

Hmmm. I’ve only used chocolatey. May i suggest uninstalling as well as possible and using chocolatey? Don’t try to use the chocolatey GUI. It is very broken and causes tons of problems. Just install chocolately and then do cinst atom. It works great.


#9

Try copying and pasting text you have written completely inside Atom. There is a chance it could be related to trying to paste text in an encoding which for some reason can’t be pasted into the editor.

Copy/paste is working fine for me on Win8.1 (using Chocolatey).


#10

Working fine for me as well, on both Win7 and 8.1, and both built from source incidentally, though I doubt that makes a difference in this case.


#11

I cannot paste eider, as mentioned above, not by CTRL+V and not by Menu > Paste, BTW, the menu > paste mentions “Shift + Ins”. Is this normal ?

I am on Windows 7 running on MacBook air hardware. I don’t have an INS button :smiley:


#12

Yes. Traditionally, there are two copy/paste methods on both Windows and Linux: The Ctrl-C / Ctrl-V method and the Ctrl-Ins / Shift-Ins method.
Atom supports both

Just to confirm, you’re still getting the same issue when starting Atom in safe mode (atom --safe), yes?.


#13

Yes, I tried in safe mode too, same issue.
I tried by typing this in the command prompt:

D:\programs\Atom\atom.exe --safe

and by adding --safe to the program shortcut path
Maybe installing it in another drive than windows drive has something to do with it ?


#14

Paste is also broken for me. I’ve tried the steps in the debugging guide to no avail. Safe mode was no different, I have nothing in my init script, keymap, stylesheet, or config (at least nothing that Atom didn’t put there itself). I’m pretty sure I haven’t installed any additional plugins (maybe a color theme or two, can’t remember).

Both CTRL-v and “paste” in the context menu fail to paste otherwise paste-able text from the clipboard. CTRL-v is triggering core:paste according to the key resolver, but no text is actually pasted. This is a problem for text from other editors and text generated in the same document in Atom.

I have version 0.132.0 for Windows 8.1, although it has been broken at least since 0.125 or so.


#15

I am having the exact same issue. I installed via downloading the Windows zip. I’m on Windows 7, using Atom version 0.139.0 . The key resolver does show core:paste when I try CTRL+V but no text appears. I’ve tried pasting text copied from within the same document in Atom and also externally copied text to no avail.


#16

I was able to copy paste text in 0.140 under windows 8.1 without problems. I have installed it using chocolatey.


#17

I just reinstalled it with Chocolatey and am still having the same issue.


#18

Same issue on 2 different computers. Both installed via chocolatey


#19

I am having the same issue. I really love atom. Problably my favourite text editor I have ever used but, since nobody has come out with a fix for this, I cannot use it.


#20

Yup, same here. Paste not working, tried everything. Won’t paste even from within Atom. We need a fix! This pretty much renders it useless!