'...' is not recognized as an internal or external command


#1

Hello all,

I’ve been trying to get atom working all day. I plan on using it to run c programs. The problem is I keep getting this error when I run any code:

‘E:\Temp’ is not recognized as an internal or external command, operable program or batch file.

Keep in mind the ‘‘E:\Temp’’ is only there because I had my settings configured to compile to temporary directory.
If I choose not to use that setting, the same error comes up but for “C:\atom”.

My PATH appears to be properly configured, with the MinGW and the atom directory. cmd prompt will run gcc --version and atom --version properly.

I’ve checked just about every forum and article I could find, any help or ideas are appreciated at this point.

Thanks


#2

Atom does not have any ability to run code, so you must be using a package. Which one would that be?


#3

I’m using the gpp-compiler package. Some new information: I can get code to run sometimes, but only when I make new project folders on my C drive (where atom is). The typical process goes like this: I make a Folder on my C: drive, I open the folder on Atom, I select to make a new source file, I run the code and get the “compiler error” that it can’t find MinGW, I run it again and it works.

However, my source code cannot be saved in any sub-folders, or else I get the error. As soon as the code fails, it’s like the entire folder is “cursed” and the error pops up every time no matter what. I also can’t seem to reuse the folder name or else I get the error.


#4

Mind sharing a screenshot of your Atom window with the files you’re running open in the tree view? What are the current settings of your gpp-compiler package? The more I know about your environment, the better a chance I have of figuring out exactly what’s going on, and part of that is the state that Atom is in when you try to run the package.

This is something that wasn’t mentioned in your first post. What’s the exact text of that error?


#5

I’ll attach a screenshot of my settings. I tried to get the compiler error run this morning but it won’t seem to happen anymore. Now the only issue has to do with the main error I have been getting. Like I said, I can make a new folder on my C drive, and I can run any program I want - Atom works perfectly. I get the “not recognized…” in cmd when I a) create subfolders in that folder, and then try to run something from one of them (however this only occurs sometimes) b) Name the folder the same as another folder that previously had the problem, but I deleted. As you can see in the pictures, I run from a folder named “test5” - a name I’ve never used before, and it works. I run from “Source File”, and I get the error (the name of a folder that had the problem before, but was deleted). If my settings are configured to go to temp it also fails, maybe because temp is on my hard drive.


#6

I think it’s something different. I think the more likely explanation is that the space in the folder name is what’s causing the issue.