Is anyone else having --dev problems with 139 and 140?


#1

I haven’t been able to upgrade to 139 or 140 because dev mode has this bizarre problem where core packages don’t load but add-on packages do. It is the opposite of safe mode. This happens on my windows workstation and windows laptop. I’ve had an issue going on atom/atom but I was curious if I was alone on this.
.


#2

I haven’t encountered it, no. Sorry :disappointed:


#3

Warning: this is a windows rant unrelated to any Atom technical info …

You don’t have to suffer the hell that is windows.

I have been so frustrated with windows that I’m thinking of switching to a Mac, even though I have several windows machines to maintain and I’d have to learn how to use a mac. I used a Mac as my only machine for many years but that was a few eons ago. I had to switch to windows even before x86 macs came out.

I happen to know unix well. Could I pretty much use a Mac as a unix machine? I would use a linux desktop except that every time I try I’m grossed out at how it pales to mac/windows.

I even have a mac mini that is about a year old here that I use for cross-platform testing. Would that work as decent dev machine?

Since I’m ranting anyway let me tell my latest windows horror story. About every day or two windows forces my PC to reboot against my will. It flat-out says it’s going to reboot in 15 minutes whether I like it or not. Then it spends 10 minutes grinding away installing updates. Then it comes back up and says the updates failed. The it grinds for another 10 minutes rolling the updates back. It does this over and over.

Of course I’m sure there are Mac horror stories also.


#4

Yes and yes! The minis are quite capable. Personally I can’t go back to developing on Windows after having the benefits of both a good UI and POSIX compatible OS. It doesn’t take long to get used to it either.


#5

There are Mac horror stories also, but in my experience they are fewer. I happily used Windows (and poo-pooed Mac) for over 20 years … but gave Mac a try four years ago and then slowly converted. I honestly don’t see myself ever going back to Windows at this point.

OS X is a flavor of BSD Unix as I’m sure you know. So yes, you can use it as a Unix machine. It has its unique bits … but in my experience all flavors of Unix have their parts where they differ from the “standard” for one reason or another. Overall though, I feel like OS X is the “user-friendly Unix” that was the holy grail that many desktop Linux flavors were claiming to be ten years ago.

That’s how I started when I converted.

How the OS handles updates is the most glaring difference for me. OS X simply respects the user’s time. Almost all Windows updates require a reboot, in my experience. And while it may download updates while you’re away from the machine or in the middle of the night … it requires you to be there, taking up your time, when they install. Why? With OS X, by contrast, you can click a button and it’ll try to install the updates when you’re not using the machine … even waking itself up in the middle of the night to do so if you’d like.

So yeah … I don’t blame you for being frustrated with Windows, especially for development on open-source projects like Atom.


Renaming a package
#6

I use them all, Windows 8 on Acer laptop, Mavericks on iMac (I do not like yet Yosemite, I will install this release again after Christmas, for now I don’t like it, is heavy) and also I use Ubuntu on my Acer laptop. Never had problems with updates or anything else, never. I do development at home on OSX and at work on Windows. I use sometimes Ubuntu at home. As web developer and designer Windows and OSX is my main workstations (Adobe Creative Cloud) and for example (little off topic) I need a lot of times to check my applications on Internet Explorer (yes a lot of people use this browser, all the rest about Chrome and bla bla bla is marketing).

Windows 8 and Mavericks is both very very good operating systems. Make clean install on everything (Windows, OSX, Ubuntu) and on Windows select your security software very careful (first do all updates and then install anything else). Most of the times Internet security software causing problems to updates (on windows I use free Comodo without problems) or perhaps you have virus.


#7

While I agree that an expertly configured Windows machine works fine, I completely understand mark_hahn’s frustrations with the updates. This comes from the basic philosophy behind the OS: in Windows, the OS decides what’s good for you and shoves things in your face until you deal with them. In OS X, you get all the same info, but in a way that tries not to be too intrusive. You get a chance to deal with things when YOU want to instead of when the OS has arbitrarily decided you should. This is a big part of the reason why I personally prefer OS X in a professional environment, I’ve even seen a public speaker standing around helplessly halfway through a presentation because his laptop had decided to use the opportunity to install updates. This is an extreme case, and the argument can be made that he should have checked for this sort of thing beforehand, but still, in OS X the audience wouldn’t even have to notice anything…


#8

I’m just glad that at this point in my career I have a choice in both my personal and professional life what platform I want to develop on and for.


#9

I use a chromebook for everything except development, which is slowly getting to be just Atom. Chromebooks are awesome. My wife switched from her small Dell laptop and loves it also.

There is basically no OS, which is awesome. I have never ever seen anything like an update although I know they are happening since a UI will change now and then. And you can drop down to unix like a Mac.

One of my wife’s apps quit working and I told her to try rebooting it. She looked at me funny and said “I didn’t know you could reboot a chromebook”. I had to show her where the power key was. And she had used it for six months or so.


#10

In all honesty I think I know what my windows stability problem is. I have run as administrator on all windows since the beginning. I’ve also always disabled all login. I took the trouble to set up windows 8 so that administrator is the only user.

It has never allowed me to go to the windows store which I assume is some kind of security thing. It has been bugging me for a long time to upgrade to 8.1 but you have to go to the store to do that. I guess I should give in and make a normal user. But I’m an obstinate old cuss.

And I always do sudo -i as my first command on logging in to linux to always run as root. I have been doing this for 20 years. I haven’t ever accidentally run rm -rf /. The only downside I’ve run into is that I have to use the --unsafe operation to get node-gyp to work.


#11

Just wanted to chime in and say I also have this problem on 139 and 140. I kept an eye on the forums and seeing nothing about it I figured I was the only one until I saw Mark posted it a few days ago.

Some information:
Windows 8.1, manual Atom install (no Chocolatey) to C:\Applications\Atom.

Tried deleting:
.atom
C:\Users\Philippe\AppData\Roaming\Atom
Doesn’t make a difference. I’m unaware of any other places Atom stores files in.

Getting the following error:

Error compiling Less stylesheet: c:\Applications\Atom\resources\app\node_modules\base16-tomorrow-dark-theme\index.less
Line number: 47
variable @light-gray is undefined c:\Applications\Atom\resources\app\src\theme-manager.js:335
Error compiling Less stylesheet: c:\Applications\Atom\resources\app\node_modules\base16-tomorrow-light-theme\index.less
Line number: 28
variable @very-light-gray is undefined c:\Applications\Atom\resources\app\src\theme-manager.js:335
Error compiling Less stylesheet: c:\Applications\Atom\resources\app\node_modules\solarized-dark-syntax\index.less
Line number: 3
'variables.less' wasn't found c:\Applications\Atom\resources\app\src\theme-manager.js:335
Error compiling Less stylesheet: c:\Applications\Atom\resources\app\node_modules\solarized-light-syntax\index.less
Line number: 3
'variables.less' wasn't found c:\Applications\Atom\resources\app\src\theme-manager.js:335
Failed to activate theme 'atom-dark-syntax' because it isn't installed. c:\Applications\Atom\resources\app\src\theme-manager.js:378
Failed to activate theme 'atom-dark-ui' because it isn't installed. c:\Applications\Atom\resources\app\src\theme-manager.js:378

A screenshot to show how it looks like:

Observations:

  • Core packages are not activated.
  • Personal packages are activated (not visible in screenshot, removed .atom for it).

Running atom --dev --safe solves the problem. Without the --safe flag it refuses to load the core packages. Since this also occurs when the personal folders are removed, it cannot be a package causing the issue. It looks like it does the opposite of ‘safe’ mode in normal mode: loading user packages but ignoring core packages.

If any other information or testing is required I’d be happy to provide and help with it.


#12

Can you add the --dev --safe information to the bug that @mark_hahn filed?


#13

Done.

To add to the off-topic Windows discussion, while making the post I renamed the .atom folder to .atom.backup. When I tried to rename it back I got the following message:

Had to run mv .atom.backup .atom in Git Bash to rename it…
Windows manages to surprise me at the most unexpected times.


#14

I converted a while ago, and I didn’t have any issues. The user-friendly aspects of OSX are so user-friendly that it’s not hard to pick them up, and the Unix aspects are, well, Unix.

I haven’t tried, however, using OSX as root. I just went with the flow and created a user account when I installed it. In case root is needed, I use sudo. It’s not too much of a pain.


#15

In windows to rename a file to something starting with a dot just add a dot at the end too.