Invisible text in UI text boxes


#1

After several uninstall/reinstall and multiple UI themes, I am unable to see text in any UI controls (example Find/Replace boxes). I can type and add text to the controls and DevTools reveals that the text is added to the markup; however no letters are visible in control.

I’m not sure when it stopped working, had worked fine for many moons.


#2

screen grab showing blank control.

Image%203


#3

Do you have anything in your styles.less (File -> Stylesheet...)?


#4

styles.less was not present in my .atom/ folder. but the UI created me a new one that is blank. no change in the behavior.


#5

What happens when you start Atom from the command line with atom --safe?


#6

This is mac os, So, I opened atom thusly:
$ open -a atom --args --safe

The problem persists


#7

You can open atom an macOS with atom --safe too.


#8

Noticing that DevTools shows 1 error:


#9

thanks for clarifying. I’m a mac noob.


#10

atom.io still not showing contents of UI text boxes… I’ve reinstalled again. Really need to sort this out.

Noticing with dev tools that I can find the typed text, but that it isn’t visible in the UI. Any help would greatly appreciated.


#11

I don’t see anything that I understand to be able to cause that issue.


#12

Misbehaving font?
The syntax theme looks strange too.


@grektokomus:
Greg, have you tried yet to change the theme being used? Do you see any change in colours and other behaviours?


#13

Hi,

I face the same issue with MacOS 10.13.5. I tracked it down a little further. The inputs in the search box gets invisible starting with atom version 1.25.0. All prior versions like 1.24.1 work fine.

I don’t have any templates installed and just use the default ones, also no custom styles are used in style file.

It would be great if you could find the cause. I am willing to help!

Best regards


#14

@blablub121 - Your tip is extremely helpful!

:smile: Should I suggest to avoid the issue, switch over to Windows? (just joking)

:thinking: Could you check the version number of the find-and-replace package,
if you still have Atom V1.24.1 installed.

The best result forward would be to create an issue at the package.
Would you mind doing that for the community. Please.
( https://github.com/atom/find-and-replace/issues )
Do make sure to fill out the template - without it the issue might get scrubbed.
Let this Forum know so that guys like @grektokomus can subscribe to it.

Thanks in advance. Good luck.


#15

@danPadric I think it is not only related to find-and-replace

This behaviour is all over atom. Also on 1.24.1 I have weird behaviour on other places like settings:

Inputs are kinda hidden as long as you click the input field.

Just for completion: find-and-replace version is 0.215.0.


#16

Ok while creating the issue, I did all the debugging stuff and with using the --disable-gpu switch everything worked fine again. So it’s related to my gpu, (mid 2010 mbp pro with broken nvidia gpu :laughing:).

@grektokomus maybe this switch fixes your issue too.

@danPadric do you know a way to force this switch in settings of atom?


#17

Thanks for making that clear!


Nice!! catch.


Not without looking around first.

Unrelated to Atom, I have had issues with a graphic card and an application (simulation of industrial equipment). The solution there was to tell the graphic card to not engage for that application but use the built-in Intel graphic instead. Do you have such option?

Plan B … it is possible for me to edit the shortcut to the Atom application as to include the --disable-gpu switch. Even making a small batch file is an option. Because I have never touched a Mac, I will not be able to assist on this suggestion.

What are your thoughts?


#18

I have done a full uninstall/reinstall and then used the default theme (for both UI and Syntax my default is “One Dark”).

The issue persists. I have also tried various themes, but each time, the search box is invisible.


#19

@grektokomus Something that seems odd from your screenshot is the big font-size of 54px. Do you mind opening the “font-size” node to see where this big number comes from. Although that shouldn’t be the reason why the text is invisible, but maybe a hint from where the styles are set.

50%20AM

It also appears that the .lines element has some inline styles disabled:

28%20AM

I can reproduce the disappearing of the text by disabling some of these styles:

Could it be you disabled them when trying to debug the issue? By default, these styles should all be enabled.


If it is GPU/graphics card related, based on the above, might be worth to play around with that contain: strict; property? Does it have an effect if you paste the following your styles.less file:

atom-text-editor[mini] * {
  contain: initial !important;
}

It should reset all elements in the mini editor back to the default. There are also other available values: https://developer.mozilla.org/en-US/docs/Web/CSS/contain.

@blablub121 Might also be worth trying in your case, so you don’t have to use a script to disable the GPU.


#20

Hi All,

Sorry about that screen shot; as you guessed, I provided a screenshot that showed settings I had deactivated in trying to make the text visible. …and the font size was originally 14px.

Using --disable-gpu has eliminated the issue.

I’ve tried every value for contain, and none of them resolved the issue.

I appreciate the responses of @blablub121 and @danPadric as well… humbled by the commitment and brain power. --thanks.