Installing “script@3.25.0” failed

I get error while installing script on atom. I am using wifi with proxy I configurated apm proxy and it worked while installing platformio-ide-terminal. but for script it gives thoses errors. Please help.

Installing “script@3.25.0” failed.Hide output…

npm WARN registry Using stale package data from https://registry.npmjs.org/ due to a request error during revalidation.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: coffeescript@^2 (node_modules\script\node_modules\coffeescript):
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: 502 Bad Gateway: coffeescript@^2
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: babel-cli@^6.26.0 (node_modules\script\node_modules\babel-cli):
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: 502 Bad Gateway: babel-cli@^6.26.0

npm ERR! code E502
npm ERR! 502 Bad Gateway: ansi-to-html@^0.4.2

npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\DELL.atom.apm_logs\2020-02-04T19_29_59_224Z-debug.log