Installing packages


#1

Hi everyone. I recently started using atom. I downloaded the atom-windows.zip and started using atom.exe.
I am not able to download packages. Please help me.


#2

Have you followed the suggestions in the Debugging document? Also, could you give the following information?

  • Which version of Atom are you using?
  • What OS and version are you running?
  • Can you reproduce the issue after completely exiting Atom and restarting using atom --safe?

#3
  • I am using Atom - 1.5.3 version
  • I am using Atom on windows 10 pro

I downloaded atom-windows.zip folder and extracted it and straight away started using “atom” by clicking “atom.exe” file. I tried installing package from application itself but it didn’t installed. So I cloned the package from github into .atom\packages folder using reference from internet. To install it said to use “npm” command; I tried it in command prompt but it the command is not working.
Please help me in solving it.
Thank you.


#4

What error message did you get?

Are you trying to install packages from behind a firewall?

Frankly, those instructions are wrong. “npm” isn’t a tool for installing Atom packages. “apm” is the tool to use to install Atom packages if you want to do it from the command line.