Installing “atom-keyboard-macros@0.12.1” failed


#1

What’s Wrong?


Installing “atom-keyboard-macros@0.12.1” failed.Hide output…

keyboard-layout@2.0.14 install C:\Users\kreat\AppData\Local\Temp\apm-install-dir-118919-36688-17vn7uu.upba\node_modules\atom-keyboard-macros\node_modules\keyboard-layout
node-gyp rebuild

C:\Users\kreat\AppData\Local\Temp\apm-install-dir-118919-36688-17vn7uu.upba\node_modules\atom-keyboard-macros\node_modules\keyboard-layout>if not defined npm_config_node_gyp (node “C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\npm\node_modules\npm-lifecycle\node-gyp-bin\…\node_modules\node-gyp\bin\node-gyp.js” rebuild ) else (node “C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\bin\…\node_modules\node-gyp\bin\node-gyp.js” rebuild )

npm WARN deprecated coffee-script@1.12.7: CoffeeScript on NPM has moved to “coffeescript” (no hyphen)
gyp info it worked if it ends with ok
gyp verb cli [ ‘C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\bin\node.exe’,
gyp verb cli ‘C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\node-gyp\bin\node-gyp.js’,
gyp verb cli ‘rebuild’ ]
gyp info using node-gyp@3.4.0
gyp info using node@8.9.3 | win32 | x64
gyp verb command rebuild
gyp verb command clean
gyp verb clean removing “build” directory
gyp verb command configure
gyp verb check python checking for Python executable “python2” in the PATH
gyp verb which failed Error: not found: python2
gyp verb which failed at getNotFoundError (C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\which\which.js:13:12)
gyp verb which failed at F (C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\which\which.js:68:19)
gyp verb which failed at E (C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\which\which.js:80:29)
gyp verb which failed at C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\which\which.js:89:16
gyp verb which failed at C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\isexe\index.js:42:5
gyp verb which failed at C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\isexe\windows.js:36:5
gyp verb which failed at FSReqWrap.oncomplete (fs.js:152:21)
gyp verb which failed python2 { Error: not found: python2
gyp verb which failed at getNotFoundError (C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\which\which.js:13:12)
gyp verb which failed at F (C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\which\which.js:68:19)
gyp verb which failed at E (C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\which\which.js:80:29)
gyp verb which failed at C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\which\which.js:89:16
gyp verb which failed at C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\isexe\index.js:42:5
gyp verb which failed at C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\isexe\windows.js:36:5
gyp verb which failed at FSReqWrap.oncomplete (fs.js:152:21) code: ‘ENOENT’ }
gyp verb check python checking for Python executable “python” in the PATH
gyp verb which failed Error: not found: python
gyp verb which failed at getNotFoundError (C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\which\which.js:13:12)
gyp verb which failed at F (C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\which\which.js:68:19)
gyp verb which failed at E (C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\which\which.js:80:29)
gyp verb which failed at C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\which\which.js:89:16
gyp verb which failed at C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\isexe\index.js:42:5
gyp verb which failed at C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\isexe\windows.js:36:5
gyp verb which failed at FSReqWrap.oncomplete (fs.js:152:21)
gyp verb which failed python { Error: not found: python
gyp verb which failed at getNotFoundError (C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\which\which.js:13:12)
gyp verb which failed at F (C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\which\which.js:68:19)
gyp verb which failed at E (C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\which\which.js:80:29)
gyp verb which failed at C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\which\which.js:89:16
gyp verb which failed at C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\isexe\index.js:42:5
gyp verb which failed at C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\isexe\windows.js:36:5
gyp verb which failed at FSReqWrap.oncomplete (fs.js:152:21) code: ‘ENOENT’ }
gyp verb could not find “python”. checking python launcher
gyp verb could not find “python”. guessing location
gyp verb ensuring that file exists: C:\Python27\python.exe
gyp ERR! configure error
gyp ERR! stack Error: Can’t find Python executable “python”, you can set the PYTHON env variable.
gyp ERR! stack at failNoPython (C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\node-gyp\lib\configure.js:449:14)
gyp ERR! stack at C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\node-gyp\lib\configure.js:404:11
gyp ERR! stack at C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\graceful-fs\polyfills.js:284:29
gyp ERR! stack at FSReqWrap.oncomplete (fs.js:152:21)
gyp ERR! System Windows_NT 10.0.17134
gyp ERR! command “C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\bin\node.exe” “C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\node-gyp\bin\node-gyp.js” “rebuild”
gyp ERR! cwd C:\Users\kreat\AppData\Local\Temp\apm-install-dir-118919-36688-17vn7uu.upba\node_modules\atom-keyboard-macros\node_modules\keyboard-layout
gyp ERR! node -v v8.9.3
gyp ERR! node-gyp -v v3.4.0
gyp ERR! not ok
npm WARN enoent ENOENT: no such file or directory, open ‘C:\Users\kreat\AppData\Local\Temp\apm-install-dir-118919-36688-17vn7uu.upba\package.json’
npm WARN apm-install-dir-118919-36688-17vn7uu.upba No description
npm WARN apm-install-dir-118919-36688-17vn7uu.upba No repository field.
npm WARN apm-install-dir-118919-36688-17vn7uu.upba No README data
npm WARN apm-install-dir-118919-36688-17vn7uu.upba No license field.

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! keyboard-layout@2.0.14 install: node-gyp rebuild
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the keyboard-layout@2.0.14 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\kreat.atom.apm_logs\2018-10-19T03_15_39_736Z-debug.log
Installing “atom-keyboard-macros@0.12.1” failed.Hide output…

keyboard-layout@2.0.14 install C:\Users\kreat\AppData\Local\Temp\apm-install-dir-118919-36688-17vn7uu.upba\node_modules\atom-keyboard-macros\node_modules\keyboard-layout
node-gyp rebuild

C:\Users\kreat\AppData\Local\Temp\apm-install-dir-118919-36688-17vn7uu.upba\node_modules\atom-keyboard-macros\node_modules\keyboard-layout>if not defined npm_config_node_gyp (node “C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\npm\node_modules\npm-lifecycle\node-gyp-bin\…\node_modules\node-gyp\bin\node-gyp.js” rebuild ) else (node “C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\bin\…\node_modules\node-gyp\bin\node-gyp.js” rebuild )

npm WARN deprecated coffee-script@1.12.7: CoffeeScript on NPM has moved to “coffeescript” (no hyphen)
gyp info it worked if it ends with ok
gyp verb cli [ ‘C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\bin\node.exe’,
gyp verb cli ‘C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\node-gyp\bin\node-gyp.js’,
gyp verb cli ‘rebuild’ ]
gyp info using node-gyp@3.4.0
gyp info using node@8.9.3 | win32 | x64
gyp verb command rebuild
gyp verb command clean
gyp verb clean removing “build” directory
gyp verb command configure
gyp verb check python checking for Python executable “python2” in the PATH
gyp verb which failed Error: not found: python2
gyp verb which failed at getNotFoundError (C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\which\which.js:13:12)
gyp verb which failed at F (C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\which\which.js:68:19)
gyp verb which failed at E (C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\which\which.js:80:29)
gyp verb which failed at C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\which\which.js:89:16
gyp verb which failed at C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\isexe\index.js:42:5
gyp verb which failed at C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\isexe\windows.js:36:5
gyp verb which failed at FSReqWrap.oncomplete (fs.js:152:21)
gyp verb which failed python2 { Error: not found: python2
gyp verb which failed at getNotFoundError (C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\which\which.js:13:12)
gyp verb which failed at F (C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\which\which.js:68:19)
gyp verb which failed at E (C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\which\which.js:80:29)
gyp verb which failed at C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\which\which.js:89:16
gyp verb which failed at C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\isexe\index.js:42:5
gyp verb which failed at C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\isexe\windows.js:36:5
gyp verb which failed at FSReqWrap.oncomplete (fs.js:152:21) code: ‘ENOENT’ }
gyp verb check python checking for Python executable “python” in the PATH
gyp verb which failed Error: not found: python
gyp verb which failed at getNotFoundError (C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\which\which.js:13:12)
gyp verb which failed at F (C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\which\which.js:68:19)
gyp verb which failed at E (C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\which\which.js:80:29)
gyp verb which failed at C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\which\which.js:89:16
gyp verb which failed at C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\isexe\index.js:42:5
gyp verb which failed at C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\isexe\windows.js:36:5
gyp verb which failed at FSReqWrap.oncomplete (fs.js:152:21)
gyp verb which failed python { Error: not found: python
gyp verb which failed at getNotFoundError (C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\which\which.js:13:12)
gyp verb which failed at F (C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\which\which.js:68:19)
gyp verb which failed at E (C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\which\which.js:80:29)
gyp verb which failed at C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\which\which.js:89:16
gyp verb which failed at C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\isexe\index.js:42:5
gyp verb which failed at C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\isexe\windows.js:36:5
gyp verb which failed at FSReqWrap.oncomplete (fs.js:152:21) code: ‘ENOENT’ }
gyp verb could not find “python”. checking python launcher
gyp verb could not find “python”. guessing location
gyp verb ensuring that file exists: C:\Python27\python.exe
gyp ERR! configure error
gyp ERR! stack Error: Can’t find Python executable “python”, you can set the PYTHON env variable.
gyp ERR! stack at failNoPython (C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\node-gyp\lib\configure.js:449:14)
gyp ERR! stack at C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\node-gyp\lib\configure.js:404:11
gyp ERR! stack at C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\graceful-fs\polyfills.js:284:29
gyp ERR! stack at FSReqWrap.oncomplete (fs.js:152:21)
gyp ERR! System Windows_NT 10.0.17134
gyp ERR! command “C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\bin\node.exe” “C:\Users\kreat\AppData\Local\atom\app-1.31.2\resources\app\apm\node_modules\node-gyp\bin\node-gyp.js” “rebuild”
gyp ERR! cwd C:\Users\kreat\AppData\Local\Temp\apm-install-dir-118919-36688-17vn7uu.upba\node_modules\atom-keyboard-macros\node_modules\keyboard-layout
gyp ERR! node -v v8.9.3
gyp ERR! node-gyp -v v3.4.0
gyp ERR! not ok
npm WARN enoent ENOENT: no such file or directory, open ‘C:\Users\kreat\AppData\Local\Temp\apm-install-dir-118919-36688-17vn7uu.upba\package.json’
npm WARN apm-install-dir-118919-36688-17vn7uu.upba No description
npm WARN apm-install-dir-118919-36688-17vn7uu.upba No repository field.
npm WARN apm-install-dir-118919-36688-17vn7uu.upba No README data
npm WARN apm-install-dir-118919-36688-17vn7uu.upba No license field.

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! keyboard-layout@2.0.14 install: node-gyp rebuild
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the keyboard-layout@2.0.14 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\kreat.atom.apm_logs\2018-10-19T03_15_39_736Z-debug.log


#2

Look at the line containing the error message.

Have you installed Python? The node-gyp package, which atom-keyboard-macros relies on, has certain requirements to run, one of them being Python 2. If you follow those instructions, you should be able to install atom-keyboard-macros without a problem. You do not need to install node-gyp; it’s already included and will be useful as soon as its dependencies are in place.


#3

I don’t understand exactly.
Do I have to install Python? (I have never used Python)
Please give me a more detailed explanation of the solution.


#4

You need to install Python, yes. Follow the instructions at the site I linked and you’ll be fine.