Installing “atom-beautify@0.33.0” failed


#1

I am trying to install atom-beautify packages, and this is my first time use Atom to learn. I have been shown below output:

> npm WARN deprecated graceful-fs@2.0.3: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js
> npm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
> npm WARN deprecated minimatch@0.3.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
> npm WARN deprecated @types/commander@2.12.2: This is a stub types definition for commander (https://github.com/tj/commander.js). commander provides its own type definitions, so you don't need @types/commander installed!
> npm WARN deprecated jscs-preset-wikimedia@1.0.1: Deprecated in favour of eslint-config-wikimedia. -- https://phabricator.wikimedia.org/T118941
> npm WARN deprecated nomnom@1.8.1: Package no longer supported. Contact support@npmjs.com for more info.
> npm ERR! Windows_NT 10.0.17134
> npm ERR! argv "C:\\Users\\Quy Nguyen\\AppData\\Local\\atom\\app-1.30.0\\resources\\app\\apm\\bin\\node.exe" "C:\\Users\\Quy Nguyen\\AppData\\Local\\atom\\app-1.30.0\\resources\\app\\apm\\node_modules\\npm\\bin\\npm-cli.js" "--globalconfig" "C:\\Users\\Quy Nguyen\\.atom\\.apm\\.apmrc" "--userconfig" "C:\\Users\\Quy Nguyen\\.atom\\.apmrc" "install" "C:\\Users\\QUYNGU~1\\AppData\\Local\\Temp\\d-11882-10676-1pd8cj3.buptceg66r\\package.tgz" "--runtime=electron" "--target=2.0.5" "--arch=x64" "--global-style" "--msvs_version=2015"
> npm ERR! node v6.9.5
> npm ERR! npm  v3.10.10
> npm ERR! code EREADFILE
> 
> npm ERR! Error extracting C:\Users\Quy Nguyen\.atom\.apm\marko\4.13.3\package.tgz archive: ENOENT: no such file or directory, open 'C:\Users\Quy Nguyen\.atom\.apm\marko\4.13.3\package.tgz'
> npm ERR! 
> npm ERR! If you need help, you may report this error at:
> npm ERR!     <https://github.com/npm/npm/issues>
> 
> npm ERR! Please include the following file with any support request:
> npm ERR!     C:\Users\QUYNGU~1\AppData\Local\Temp\apm-install-dir-11882-10676-1ak13y1.o2hmklz0k9\npm-debug.log

I tried many solutions that were available online and cannot solve this problem.

Thanks for your help!


Unable to install all packages
#2

This came up recently in another thread, and we arrived at a workaround that worked. Since it’s appearing for multiple people, this might be something that can be replicated if we figure out why it’s happening.


#3

This is the first time I learn and practice with Atom, so I need some essential packages to help me solve many cases. Thanks for your reply :v , I think I must try with Git Bash …