Installiing packages through command line


#1

Not able to install packages through command line Gives following error

Atom V:1.18
OS:-WIN 8.1 WMC


Atom not showing up anywhere
#2

Is the atom command recognized? Can you install packages from inside Atom?


#3

Do u want to say GUI way?


#4

I mean to say that you should type atom into the command line and tell me if it opens an Atom window. Then try to install a package via Atom’s GUI and tell me if it works.


#5

No atom doesnt open and there is no problem in GUI I can do every operation clearly(Install ,Disable,Uninstall) I have problem only with command line


#6

Check your PATH. One of the entries should be C:\Users\Mandar\AppData\Local\atom\bin. If that isn’t there, then you should add it.


#7

Is’nt atom a global command.And every time if i want to do operation related to package installation/uninstallation i have to cd to this path
C:\Users\Mandar\AppData\Local\atom\bin ?

On CMDER


#8

Read the article I linked to. That will explain the PATH and how to view it. atom is a global command, and the bin/ folder being on the PATH is how Windows knows that it is.

If you are missing a bin folder, that’s interesting. You should delete C:\Users\Mandar\AppData\Local\atom and reinstall it. All of your packages and settings are kept in C:\Users\Mandar\.atom, so you won’t lose anything.


#9

Reinstall atom or just delete C:\Users\Mandar\AppData\Local\atom


#10

Reinstall Atom.


#11

Ok I will do it and late you know about it


#12

@rsese

I reinstalled atom but still bin folder is missing


#13

Okay. I don’t know what happened or why, but you can create a new folder named bin and download these files into it.


#14

Yeah that’s really weird, I went through the uninstall process that we talked about in the issue you have open @mandar262 then I installed Atom with the .exe installer and that directory exists in my install.

Manually creating the bin folder and adding those files (thanks for sharing those @DamnedScholar :v:) seems like a workaround that should work if your PATH is set correctly.


#16

@rsese on which OS do you tried installation and uninstallation?


#17

on which OS do you tried installation and uninstallation?

I tested on Windows 10.


#18

Should I open issue that installer is not creating bin folder?


#19

Hmmm, I don’t think so (at least not yet) since you’re having other installation problems so it’s not clear if it’s a separate issue or just related to the existing issues you’ve been having.


#20

@rsese @DamnedScholar thanks for help.!

But when new update will come then will this bin folder work?


#21

I don’t know. It will be interesting to see if it does, because it might.

If it doesn’t, then all you will have to do is change the versions in each of those files from 1.18.0 to whatever the new version is.