Installer seems to work but atom doesn't launch; Windows 7


#1

Hello all, so awhile back I had atom installed on my workstation but uninstalled it because I never used it. Now I use it at home and wanted to reinstall on my workstation but I am running into an issue.

I can run the installer, and it creates the atom.exe file in the appdata folder and briefly displays the installer splash screen, (roughly 3-5 seconds) but I can’t launch it. It seems like the installer crashes although it doesn’t produce a squirrel log or any other log that I can see.

I’m running a 64 bit Windows 7 Pro machine. I’ve tried uninstalling my antivirus as well to no avail.

Any assistance would really butter my eggroll. Thanks


#2

Open the task manager and see if there are any processes called Atom first. Report on whether or not you see them, and close them. Go into your user folder and change the name of the .atom/ folder (to anything except .atom), then try opening Atom again.


#3

No running processes with Atom in the name. I changed the folder and ran the installer again, and it recreated the atom folder with several .exe files and 2 folders. I’ll attach a screen cap of the folder and files the setup created.


#4

For some reason, the installer forgot to create a bin/ folder. This happens occasionally, and I have never seen anything that would give me a solid clue as to why. You can create your own, and populate it with these four files. After that, I think it will work normally. At the very least, I haven’t had anyone follow up with information that this fix broke for them when Atom updated. The only important information in those files is the version number, so if it does break on update it will be easy for you to fix.


I can't install packages or themes on my atom
#5

So I should be looking at something like this, atom

Still no luck. I reran the setup but it didn’t seem to work. Maybe I did something wrong with the bin files?


#6

and this


#7

What happens when you try atom -v from the command line?

You can open those files in a text editor to verify that the path to the application folder is app-1.33.1/ (which they will be if you copied my files).


#8

It just says that it cannot find atom.

I also verified the versions in the files


#9

You probably need to add AppData/Local/atom and AppData/Local/atom/bin to your PATH (something else that normally happens by default).


#10

Done. The process flashes in the process list very briefly before disappearing. I can now use atom -v from command line but it acts as if the program starts and nothing else.


#11

It should give you a version number when you use the -v switch. This is what I see:

$ atom -v

Atom    : 1.33.1
Electron: 2.0.16
Chrome  : 61.0.3163.100
Node    : 8.9.3

Now, if the command is actually connecting to the executable correctly, we can try a couple of other things in order to identify what might be causing the error. What happens if you use the command atom --safe? There’s a chance that will fix it (try atom by itself to be sure), and if not then use atom --clear-window-state. If it’s something to do with the previous installation, then those two commands should give us the answer.

This is an unusual situation, and it’s likely that some leftover data from the previous installation of Atom is still around and has been corrupted (these things happen). Fortunately, the command line switches are usually sufficient to identify and solve this problem when it comes up (and you’ll find many threads on here just like that), but in your case the problem was compounded by a different occasional occurrence in Atom not properly installing its commands.


#12

I don’t think I connected the command line to the executable properly. Any variation of atom just goes on without errors or loading anything. I can also put completely random stuff behind atom and it doesn’t error out. I would imagine it should.

atom

I would guess this is an error of some kind on my part. Should I be adding the path variables to both my system and user or just system? Or does it matter?


#13

In the command line window, navigate to the folder where Atom is installed and enter the bin/. Then you can try using it directly with atom.cmd -v, atom.cmd --safe, etc. Those files all point inside the current app folder at files inside resources/cli/, so you can test those too to see if removing layers of abstraction work (or if, for some reason, resources/cli is incorrectly installed).

It’s not uncommon for a single workstation that has had Atom installed on it twice to have some weirdness, but usually it’s because there’s something amiss in the session memory or .atom/ configs.


#14

Still nothing. I think its probably something I’m doing, or maybe not doing, due to my lack of experience. Not sure if it is worth continuing?


#15

Maybe not, but it probably is worth deleting all of the folders and reinstalling it just to see if that does anything.


#16

How do I know what folders need to be deleted? Surely there are more than the ones in /appdata/?


#17

Your user folder will have a configuration folder called .atom/. Atom also stores session data in AppData/Roaming/Atom/.


#18

Tried that without any success. I think I’m going to give this one a rest. Thanks for all your help! I really do appreciate it!