Installation problem


#1

I’m trying to do a basic installation of Electron into a Node project, by typing:
npm install --save electron

But, it’s producing an error:

bash-4.2$ npm install --save electron

> electron@1.4.1 postinstall /u/fisher23/javaNodeTest/node_modules/electron
> node install.js

Downloading electron-v1.4.1-linux-x64.zip
[============================================>] 100.0% of 43.25 MB (3.46 MB/s)
/u/fisher23/javaNodeTest/node_modules/electron/install.js:22
  throw err
  ^

Error
    at ChecksumParseError.Error (native)
    at new ChecksumParseError (/u/fisher23/javaNodeTest/node_modules/sumchecker/build.js:68:127)
    at /u/fisher23/javaNodeTest/node_modules/sumchecker/build.js:123:20
    at Array.forEach (native)
    at /u/fisher23/javaNodeTest/node_modules/sumchecker/build.js:118:38
    at ChecksumValidator.parseChecksumFile (/u/fisher23/javaNodeTest/node_modules/sumchecker/build.js:114:14)

Any ideas on why I’m getting this error? I’m using Redhat 7.

John


#2

What happens if you specify a different version? Do you get the same issue? (npm install --save electron@1.3, for example)


#3

Yea, it’s giving me the same error on that version too. I’m perplexed that it’s successfully downloading the .zip file, but then failing on the checksum. And, it “cleans up” so fast, that I can’t manually look at the .zip file to see what it’s downloaded, and why it might be a problem. I don’t see any earlier errors in the npm process when I run with --verbose.


#4

I’m not sure of the underlying issue, but I believe I’ve figured out the solution – i removed all the files in my .electron directory, and rebuilt, and it worked.